Initial situation

I have an Acer Aspire V 15 Nitro with Win 8.1 and 2 hard drives. mSATA Liteon SSD (256 GB) - operating system Samsung SSD 840 EVO 500GB - Data

More than a year ago I set a password in the BIOS for both hard disks and the BIOS itself (the same for all three). When switching on I was asked for the passwords and after input, the hard disks were unlocked and the system started.

My problem and how it happened. I have working for a while as always and around noon the system hung/crashed, windows not responding then I did a hard reset (pressed long the power key). After that I have restarted and as with every start, the passwords promt for the hard disks pops up. I could unlock the first hard disk, then entered the password for the second hard disk and I get "Incorrect Password" message. Since then I can't unlock the hard drive.

It's been a week now and since then I can't unlock the hard drive and I've read and tried many things but without success.

Summary Samsung Support

I have contact the Samsung Support, that's the result. They claim that they didn't have something like this yet and just offer me to send the SSD to them and they delete it completely after that I can use it again. However, no option for me I need the data.

The ATA security concept knows two different passwords, the user password and the master password. I got this back on the request of the master password:

Unfortunately, we have no instruction on how the ATA security concept works. Please contact the motherboard manufacturer directly and ask how to unlock the hard drive. Unfortunately we don't have a special tool or master passwords. We can only unlock the SSD in our Repair Center.

But according to this document there is such a password
At point 5.2.1 SECURITY (page 11) the master password is mentioned.

5.2.1 SECURITY mode default setting The 840 PRO is shipped with master password set to 20h value (ASCII blanks) and the lock function disabled. The system manufacturer/dealer may set a new master password by using the SECURITY SET PASSWORD command, without enabling the lock function.

However, the support did not react directly to the document.

My attempts to unlock the SSD with hdparm

ubuntu@ubuntu:~$ sudo hdparm -I /dev/sdb


ATA device, with non-removable media
    Model Number:       Samsung SSD 840 EVO 500GB               
    Serial Number:      S1DHNSAD903633N     
    Firmware Revision:  EXT0BB6Q
    Transport:          Serial, ATA8-AST, SATA 1.0a, SATA II Extensions, SATA Rev 2.5, SATA Rev 2.6, SATA Rev 3.0
    Used: unknown (minor revision code 0x0039) 
    Supported: 9 8 7 6 5 
    Likely used: 9
    Logical     max current
    cylinders   130 130
    heads       16  16
    sectors/track   63  63
    CHS current addressable sectors:      131040
    LBA    user addressable sectors:   268435455
    LBA48  user addressable sectors:   976773168
    Logical  Sector size:                   512 bytes
    Physical Sector size:                   512 bytes
    Logical Sector-0 offset:                  0 bytes
    device size with M = 1024*1024:      476940 MBytes
    device size with M = 1000*1000:      500107 MBytes (500 GB)
    cache/buffer size  = unknown
    Nominal Media Rotation Rate: Solid State Device
    LBA, IORDY(can be disabled)
    Queue depth: 32
    Standby timer values: spec'd by Standard, no device specific minimum
    R/W multiple sector transfer: Max = 1   Current = 1
    DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
         Cycle time: min=120ns recommended=120ns
    PIO: pio0 pio1 pio2 pio3 pio4 
         Cycle time: no flow control=120ns  IORDY flow control=120ns
    Enabled Supported:
       *    SMART feature set
       *    Security Mode feature set
       *    Power Management feature set
       *    Write cache
       *    Look-ahead
       *    Host Protected Area feature set
       *    WRITE_BUFFER command
       *    READ_BUFFER command
       *    NOP cmd
            SET_MAX security extension
       *    48-bit Address feature set
       *    Device Configuration Overlay feature set
       *    Mandatory FLUSH_CACHE
       *    FLUSH_CACHE_EXT
       *    SMART error logging
       *    SMART self-test
       *    General Purpose Logging feature set
       *    64-bit World wide name
            Write-Read-Verify feature set
       *    WRITE_UNCORRECTABLE_EXT command
       *    {READ,WRITE}_DMA_EXT_GPL commands
       *    Segmented DOWNLOAD_MICROCODE
       *    Gen1 signaling speed (1.5Gb/s)
       *    Gen2 signaling speed (3.0Gb/s)
       *    Gen3 signaling speed (6.0Gb/s)
       *    Native Command Queueing (NCQ)
       *    Phy event counters
       *    READ_LOG_DMA_EXT equivalent to READ_LOG_EXT
            DMA Setup Auto-Activate optimization
            Device-initiated interface power management
       *    Asynchronous notification (eg. media change)
       *    Software settings preservation
       *    SMART Command Transport (SCT) feature set
       *    SCT Write Same (AC2)
       *    SCT Error Recovery Control (AC3)
       *    SCT Features Control (AC4)
       *    SCT Data Tables (AC5)
       *    reserved 69[4]
       *    DOWNLOAD MICROCODE DMA command
       *    WRITE BUFFER DMA command
       *    READ BUFFER DMA command
       *    Data Set Management TRIM supported (limit 8 blocks)
    Master password revision code = 65534
    not frozen
    not expired: security count
        supported: enhanced erase
    Security level high
Logical Unit WWN Device Identifier: 50025388a0031dde
    NAA     : 5
    IEEE OUI    : 002538
    Unique ID   : 8a0031dde
Checksum: correct

This article served as help.

I have tried all security-unlock and disable commands with and without --user-master m, and pass the password also as scancode.

sudo hdparm --security-unlock $(printf '\x12\x12\x12\x12\x12\x12') /dev/sdb

Anything without success, always get SG_IO: bad/missing sense data

ubuntu@ubuntu:~$ sudo hdparm --security-unlock "password" /dev/sdb
security_password: "password"

 Issuing SECURITY_UNLOCK command, password="password", user=user
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 04 51 40 01 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

This is what I found about the code

70  response code=Current information (about the error etc.)
05  sense code=Illegal Request
00 00 00 00 (not valid)
0a  additional 10 bytes
04 51 40 01  (command specific)
21 04 additional sense code=Unaligned Write Command
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

Master passwords I found and tested in every possible length from 1 - 32 characters and also as ScanCode:

  • my password
  • Blank (" ")
  • "ttttttttttttttttttttttttttttttttttttttttttttt" (32 times t)
  • h20insyde

Since the security level of the SSD is set to "high" it means that you can unlock the hard disk with the master password without losing the data and according to the master password revision code = 65534 the master password has not been changed and should still have the default value.

I also built the Samsung SSD into an identical notebook and a computer all without success.

The university of texas has published an interesting article Breaking ATA Password Security, they could remove the ATA Password with A-FF Repair Station but I can not try the software because the website is offline, via the web archive I could download the software but you need a login and this can not be created.

I hope one of you can help me to unlock the SSD.

  • How do you know the SSD is any good? Can you run the Samsung magician software on it? Check the SMART status? It’s possible the firmware is just corrupt. Regardless, it doesn’t sound like anything short of a professional data recovery company might be able to help with. But not likely if the drive is encrypted. – Appleoddity Sep 26 '18 at 22:38
  • S.M.A.R.T. i.stack.imgur.com/NxmeH.png Samsung Magician Status i.stack.imgur.com/jSdLq.png – Maxim Sep 26 '18 at 23:39
  • Based on those images it looks like the drive has failed. But I’m unable to read the Samsung magician screen, sorry. The SMART status indicates the drive is failing. – Appleoddity Sep 26 '18 at 23:43
  • Definitely reinforces the importance of having backups. Do you know if the "SG_IO: bad/missing sense data" error means it's just the wrong password? And are the SMART self-tests successful, did the utilities you used run any self-tests, or just read the current historical data? – Xen2050 Sep 27 '18 at 3:54
  • If the password is wrong, the output is SECURITY_UNLOCK: Input/output error I will try to run the smart test with an other tool and post the results – Maxim Sep 27 '18 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.