0

I installed CentOS 7 using the minimal ISO on my Proxmox VPS, configured my ifcfg-eth0 file. After that I was able to use yum update, ping 8.8.8.8, connect via SSH, etc.

After following this guide to disable network manager - I'm not longer able to do anything network related, including pinging 8.8.8.8 (I get 'connect: Network is unreachable')

My ifcfg-eth0:

TYPE="Ethernet"
PROXY_METHOD="none"
BROWSER_ONLY="no"
BOOTPROTO="none"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
NAME="eth0"
UUID=...
DEVICE="eth0"
ONBOOT="yes"
HWADDR=My Virtual Mac from OVH
IPADDR=IP assigned to VPS
PREFIX="24"
GATEWAY=Correct gateway for my OVH server
DNS1=8.8.8.8
DNS2=8.8.4.4
0

Since network-manager is disabled, your resolv.conf file is not automatically generated anymore. You can just create one on /etc/resolv.conf.

nameserver 8.8.8.8 8.8.4.4
| improve this answer | |
  • Nope, /etc/resolv.conf is configured and I can't ping IP addresses. Thank you though – Jon Sep 27 '18 at 4:54
  • Check your current interfaces if you have an assigned ip address on your box. – sudo Sep 27 '18 at 5:52
  • how do I do that? – Jon Sep 27 '18 at 5:53
  • You can check by entering ip a – sudo Sep 27 '18 at 5:55
  • lo is inet 127.0.0.1/8, eth0 is inet IP/24 – Jon Sep 27 '18 at 6:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.