1

So, this problem kinda started yesterday when my uncle gave me his extra Sony 8GB pen drive to copy some videos. I copied the files and everything went well until I reinserted the drive about three hours later and saw the following message:

You need to format the disk in Drive G: before using it. Do you want to format it?

Well, I clicked yes and it showed me a message informing me that windows was unable to format the drive. From there I went looking at EaseUS Partition Master (They were mentioned somewhere on forums in windows 10. Dunno.), HP Utility for USBs then finally diskpart. Nothing worked. Its just an 8GB drive so I could replace it in a flash even if it cost me half my pocket money, but the problem is that the drive isn't mine and if I told my uncle that I broke it, I'd be dead. Literally. So here's some of the things I did and their images. Hope someone can help. :(:(

Disk Details mbr conversion Partition Error

I followed this guide, just for information. How to recover a partially formatted USB

  • What did the log said? – dmb Sep 27 '18 at 11:28
3

The bad news: The failure of CLEAN ALL says enough: It is dead. Throw it away. It is not repairable.

The good news: You didn't break it intentionally. It could already have been partially failing before you started. A partially bad stick may allow you to write some files to it (without apparent error). There is no way to tell until you try to read the files back from the stick if they were written properly.

You didn't notice that it had happened until you put the stick back in the computer.
(And you wouldn't have had any other warning or would have had any way of preventing this happening.)
If you had just given the USB stick back to your uncle he would have been the one to discover it was bad.
Consider this: If he discovered it was bad did he break it himself simply by putting it in his computer or did you break it be putting stuff on it ? There is no way to tell for certain.

Thing is: Any flash-chip is subject to spontaneous failure at some point anyway.
USB sticks don't use the best quality chips either. (They is little profit-margin in them. Quality isn't much of a concern for the manufacturer.)
The low quality ones just go bad quicker.
If you are really unlucky sometimes even after been used only a few times.

So just tell you uncle that you discovered the stick happened to be bad when you tried to put the files on it. If he wants the files he should give you another stick.

If he insists that is was your fault it went bad he needs to be educated about USB sticks.
I do realize that trying to convince an older family member that he is wrong might be complicated. I can't really help you with that.

  • Although it's unlikely, I wouldn't necessarily say it is the flash drive, it could be the USB-Port or a combination of both. – Albin Sep 27 '18 at 13:15
  • @Albin In theory you are right, but the odds are very, very small. Especially as the controller on the stick is still addressable (Windows recognizes the stick), but writes fail (possibly controller has set itself to readonly mode which is fairly normal if the controller thinks its flash is bad) I think we can rule out a faulty USB port. – Tonny Sep 27 '18 at 13:39
  • In my admin days I learned the hard (and expensive) never to rule out s.th. completely before having a definite conformation ;D So I wouldn't say it's theoretical but granted it's unlikely (and I would still confirm it before throwing out the stick). – Albin Sep 27 '18 at 13:52
  • @Albin I would at least try the USB stick on a different computer. I had a case some years ago of a virus-infected PC were the virus corrupted every USB stick you put in there. Apparently the virus tried to infect the stick but was badly programmed. Took a while before we figured out that it wasn't the USB controller in that PC (as luck had it it only had a single controller, so the problem appearing on the other USB ports in that PC was expected). – Tonny Sep 27 '18 at 15:59
  • I tried it on a different computer and it didn't work. I can open other flash drives so I doubt that it is the ports fault. I'm giving up on it, I guess. I bought a new 32 GB one for uncle. – Shreya Pattnaik Sep 30 '18 at 16:13
1

I suspect as well that the pen drive is defective. But on the off chance it's not AND you're USB port (HW and SW like driver etc.) isn't faulty either. You could use a third party application to erase and reformat the drive. In certain cases diskpart seems to cause problems (not for me but in cases other users used it). Here's one of my answers explaining how.

  • I'll try the answer and see if it works. If it won't I guess that ones goes into a corner of the house I won't venture into. – Shreya Pattnaik Sep 30 '18 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.