2

I have two machines: an old one (core i7-920/12 GB RAM) and a new one (AMD 1950X, 96 GB RAM). Both machines have Ubuntu 18.04 and Windows 10 in a dual boot setup. When I backup my NAS on the old one, everything is ok and when backing up on the new one, the system hangs after some time (about half an hour), regardless of operating system.

More detailed: I backup my NAS on an external USB disk. I have created a Truecrypt container on the USB disk and I use FreeFileSync to sync the USB files with the NAS. On all systems the NAS is mounted as a SAMBA share. The truecrypt container is NTFS formatted. This regime worked well when I had 500 GB disks as backup on all machine/system combinations. I recently bought two 4TB disks as the NAS threatened to outgrow my backup disks. Each disk contained two Truecrypt containers, one of 1.5 TB and one of 2 TB. On the old machine everything works fine: top speeds of 86 MB/s on a 1 GB/s LAN.

On the new machine everything hangs in all phases on both OS'es. Creating a Truecrypt container starts ok, but after formatting some time (half an hour? didn't clock) Truecrypt hangs. I could create and format a Truecrypt container on the old machine and mounted this disk at the new machine. Mounted as well in Truecrypt and did a FreeFileSync. After some time FreeFileSync hung. I actually noticed that it was no hang, but an extreme slowdown. I still can stop FreeFileSync, but that took some hours (literally). Dismounting the Truecrypt container is possible as well, but that took a nights sleep.

Does anyone have some ideas on what is going on? Is the amount of RAM too big on the new machine so that it allocates too big a disk cache? Is it the instruction set of the AMD (can't image as the smaller disk worked well).

1

Sounds more like a connection issue then anything else, especially as it hangs on both OS's. I have a personal NAS and it doesn't like multiple connections from the same user. Use freefilesync myself and it always seems to work ok.

First thing I'd try is to open task manager and then begin your back up procedure while monitoring the processes. If the laptop itself is freezing, you may be able to identify here which hardware begins peaking out - is it the CPU? RAM? Network? GPU?

If task manager all looks normal, try powering down both machines and the NAS (if possible) then just power up the new machine, followed by the NAS. Give them both a few minutes after powering up as DHCP can take a few minutes to sort itself out on IOT devices like NAS. See if that makes any difference?

Also what about your network? Presumably, both machines and NAS are connected via LAN - try replacing the cable for the new machine - make sure it's at least CAT5E. Are you going through a network switch or direct to router? How are they configured? What if you temporarily connect the NAS directly to the PC?

You can quickly rule out your query on whether the RAM is too big, although I doubt that's the issue. Reduce the RAM virtually in system settings to a lower size - here's a guide on it, works for windows 7-10: https://helpdeskgeek.com/windows-7/fix-the-maximum-amount-of-memory-usable-by-windows-7-64-bit/ Will need a restart.

Can't help more than that, but maybe the suggestions will get you going. Good luck!

1
  • Thanks a lot! I have started with your suggested experiments :-)
    – Arnold
    Sep 29 '18 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.