1

I recently migrated the DNS settings of my website to a new hosting provider (Google Firebase).

After 48 hours, the website gets indeed redirected when I visit it on my phone. On the computer however it appears to be still redirecting to the old website.

I tried to flush my dns by opening cmd and typing ipconfig/flushdns but this did not seem to work. What could be other causes?

I also tried:

  • X. nslookup mywebsite
  • Y. nslookup mywebsite 1.1.1.1
  • Z. nslookup mywebsite 8.8.8.8

and found that Y and Z point to the same desired A-record ip address but X not.

  • Please try these commands: nslookup yourwebsite.com, nslookup yourwebsite.com 1.1.1.1, nslookup yourwebsite.com 8.8.8.8 (substitute yourwebsite.com with actual URL) and post results (edit your question) – gronostaj Sep 28 '18 at 11:29
  • I dont want to give away the ip addresses, but basically I get that for the addresses for 1) ***.15 and ***.5. For 2) I get a non-authoritative answer with addresses ***.195 and ***.195. For 3) I get the same as for 2). The A records should be pointing to 2 and 3 and not to 1). – JohnAndrews Sep 28 '18 at 11:33
2

I asked you in the comments to execute three nslookup commands that query DNS servers for IP of the server that hosts your website:

  1. nslookup yourwebsite.com - queries your default DNS
  2. nslookup yourwebsite.com 1.1.1.1 - queries CloudFlare DNS
  3. nslookup yourwebsite.com 8.8.8.8 - queries Google DNS

So your default DNS is returning outdated information, while Google and CloudFlare DNS have already updated. I'd suggest switching to some more reliable DNS provider. CloudFlare has a nice website that includes DNS configuration guides.

  • Who provides exactly the DNS? The telecom company that I use to register my domain? – JohnAndrews Sep 28 '18 at 11:57
  • Usually the default DNS is provided by your ISP. If you have a router, then your devices probably send all DNS requests to the router, which in turn queries ISP's public DNS. ipconfig command will return DNS address that you're using among other data. If it's a local IP, then that device (router, probably) acts as a DNS server, probably forwarding queries to ISP DNS as I said earlier. – gronostaj Sep 28 '18 at 12:30
  • Any way to resolve that? – JohnAndrews Sep 28 '18 at 12:32
  • You can only wait, I guess - it's a problem at ISP's end, not yours. Switching to a different DNS will help (and improve domain name resolution speed, and possible improve your browsing privacy), but other people using the same DNS will still face the issue until changes propagate to that server. – gronostaj Sep 28 '18 at 12:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.