0

So I'm facing a problem I've never seen before. I have a PC that doesn't have a WiFi adapter integrated, so I bought a one. My motherboard is ASRock H110M-HDS, I have Windows 10 Pro, and the network adapter that I bought is ASUS PCE-AC51. I installed it and its drivers and it appeared to turn on fine, found all the connections nearby, but couldn't connect to them.

The way it works is that it tries to connect to a network (that has full strong signal, regardless of how many, if any, devices are connected to it) for a lengthy amount of time and then the network adaptor resets itself. It temporarily turns off for a few seconds (doesn't show any wireless adaptor installed at all) and then turns back on with a message that it failed to connect to the network. It happens almost every single time.

There are very rare cases when it manages to barely connect but still has no Internet. It doesn't restart itself when it succeeds in connecting but still takes a long time to do so. Only with my phone, it managed to connect AND have working Internet. But even then only for like 5-10 seconds, then it disconnects from the Internet but not WiFi, WiFi is still strong.

I tried playing with some settings and I tried to broadcast Internet as a hotspot from the same network card, I can connect with other devices but none of them managed to connect to the Internet from the card's hotspot. However, I found something VERY odd. When the card acts as a hotspot, I can then connect to any network with the same card and Internet works flawlessly.


So long story short, my wireless network card works and connects to the Internet ONLY if it is broadcasting WiFi signal itself as a hotspot. Does anyone know why this happens and how can I fix this? It's really inconvenient to always have to plug an Ethernet cable or USB temporarily just so Hotspot function could turn on and then it would allow me to connect to any network by doubling the WiFi field for whatever reason. It's almost like always having to jumpstart a car whenever you want to drive it.

Any help would be greatly appreciated.

  • Since it's an internal adapter, which usually connects to separate antennas in the laptop's body, I almost suspect some of the antenna wires weren't property connected... – grawity Sep 28 '18 at 11:43
  • This is a desktop PC, not a laptop. And I made sure I connected it properly to the PCIe port and connected both antennas properly multiple times. No effect. – Vince Fearlow Sep 28 '18 at 11:51
  • Ah, it is. Didn't notice that at first. – grawity Sep 28 '18 at 12:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.