0

When trying to install the current Ubuntu 18.10 (beta) desktop image (.iso) in VirtualBox (v5.2.18 r124319 for MacOS 10.13.6), I get the perennial problem of a blank screen hang after the initial splash screen. No error messages at all, just a hang. I've had this same problem with the daily 18.10 betas and was hoping that maybe it would resolve itself if I waited for the first official beta, but it hasn't.

With past Ubuntu VMs I think I've gotten past this by increasing memory for the VM, but going to 2048 MB and beyond isn't helping this time. Nor has increasing video memory or toggling 3D acceleration or the paravirtualization interface (as discussed in this thread).

Any suggestions for getting past this would be much appreciated!

5
  • does anything happen if you tap (or hold) CTRL a few times when it gets stuck? It lets you skip over some boot tasks that either don't get a response from an async operation, or have produced an error. Sep 28, 2018 at 18:20
  • Try to : (1) In the VirtualBox machine settings, turn off "3D acceleration", (2) Use a dynamically growing .vdi image if you used a fixed-sized one.
    – harrymc
    Sep 28, 2018 at 20:01
  • Thanks for the suggestions, but no, tapping or holding CTRL doesn't help. The 3D acceleration was already off, and I had already set it up for a dynamically-growing .vdi.
    – Bryan
    Sep 28, 2018 at 20:27
  • Do the regular (non-beta) Ubuntu's have the same problem?
    – Xen2050
    Sep 29, 2018 at 5:17
  • If I had this problem with regular (non-beta) Ubuntus in the past, I was able to get around it by upping the memory.
    – Bryan
    Sep 29, 2018 at 17:42

3 Answers 3

0

Yup, same here. This did it for me:

  • Boot to the black screen.
  • In VirtualBox's menu, select Input > Keyboard > Insert Alt Print Screen.
  • At the password prompt, enter user name ubuntu, empty password.
  • At the shell, enter sudo service gdm3 restart.

This git me to the desktop, with 4GB RAM, ICH9, EFI, 128MB video memory with 3D acceleration enabled - but I doubt any of this is crucial.

The install finished successfully, and from here on booting just worked.

1
  • Thanks for this. Unfortunately I don't get a prompt from Insert Alt Print Screen; nothing changes, i.e. still just a black screen... I tried using your other settings as well and that doesn't make a difference, sadly.
    – Bryan
    Oct 3, 2018 at 17:50
0

I had the same problem. Using the Synaptic software installer, I did a force reinstall of: virtualbox, virtualbox-dkms, virtualbox-guest-additions, and for good measure virtualbox-qt.

I then restarted and it worked beautifully.

1
  • It sounds like you're running Synaptic on an Ubuntu host - is that correct? My problem is that I'm trying to install an Ubuntu VM on a Mac host (using Virtual Box), and can't get the VM to boot. Or did I misunderstand your report?
    – Bryan
    Oct 9, 2018 at 14:21
0

The official version of 18.10 works fine for me. I'd say "problem solved", but I'd still prefer to have the option of pre-release testing. Hopefully things will go better with 19.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.