I updated from Ubuntu 9.10 to 10.04, and after installation, the computer restarted.

When grub loaded, all I get is a screen that says error: symbol 'grub_puts' not found

and a useless grub prompt that looks like grub_rescue>

I've tried reinstalling grub from the livecd (usb drive) following this guide: https://help.ubuntu.com/community/RecoveringUbuntuAfterInstallingWindows to no avail.

Sometimes, when I start up from the live usb, linux doesn't recognize the harddrive at all. It's not in the places menu, nor does fdisk list anything.

If anyone can help fix up grub so it recognizes and boots up the two os's I have installed, I'd appreciate it.

Also, I know little about grub, so try and make it easy to understand.

  • Maybe? > "Bug #570765 came up earlier this week and it's bringing up the fact that when installing Ubuntu 10.04 LTS on a system with another operating system present, GRUB2 will not show the other operating system once installed for the dual/multi-boot system. It doesn't matter whether the other operating system is Microsoft Windows or another Linux installation, but the GRUB2 boot-loader doesn't offer you the option to boot that OS, just Ubuntu." || phoronix.com/scan.php?page=news_item&px=ODE5Ng
    – Apache
    Commented Apr 30, 2010 at 12:28
  • Care to change your accepted answer @ladaghini? The link is broken and someone else posted the fix in an actual answer.
    – Ivo Flipse
    Commented Jul 8, 2011 at 9:40

3 Answers 3


Recovered and translated answer from Google Cache :

The solution is to reconfigure Grub. For this, you have to boot on a live cd. Then in a terminal

sudo fdisk -l

You should have a list of your hard drives, with their partitions. Find your root partition, one which ubuntu is mainly installed (/main). The example below is done with /dev/sda1 as your root partition Mount the system

sudo mount /dev/sda1 /mnt

If your /boot partition is independant (/dev/sda2 for example here), then you have to add :

sudo mount /dev/sda2 /mnt/boot


sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt

At this point, you are root on your installed system Chech that grub2 is installer apt-get install grub-pc

Create the configuration file

grub-mkconfig -o /boot/grub/grub.cfg
grub-install /dev/sda
  • Great job @Jmeyo, this is why links as answers should be banned!
    – Ivo Flipse
    Commented Jul 8, 2011 at 9:39

My installation finally booted after I ran the sequence outlined in the hyperlink shown above (RecoveringUbuntuAfterInstallingWindows) a SECOND time... even though I do not have Windows on this computer... only Ubuntu.




  • 1
    your link is broken. Care to update it?
    – Ivo Flipse
    Commented Jul 8, 2011 at 9:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .