I installed an app from Windows Store. Now I want to pass its path (location) to another app (like Run window) to run it in response to an event:

enter image description here

But it doesn't exist in Program Files or Program Files (x86) and its shortcut (in Start menu or on Desktop) hasn't an option to open file location.

enter image description here

When I try Open file location by right-clicking on the process name in Task Manager:

enter image description here

Then encounter to permission problem (though the user is administrator):

enter image description here

And if I repeat the process, but from Details tab (of Task Manager):

enter image description here

Finally, I see a related executable file in Windows Explorer. But when try to open it directly:

enter image description here

3 Answers 3


UWP type app no exe file like classic application. It's app package. You can read this article to understand it well.

Source: https://docs.microsoft.com/en-us/windows/uwp/packaging/packaging-uwp-apps


UWP Apps such as Xbox Companion and others downloaded from the Windows Store do have an EXE, in fact some even have two or more. There’s a run command that opens a file explorer windows showing all the apps and you can even set as desktop shortcuts but copy and pasting them.

The file path to UWP apps has the hidden attribute in Program Files, which you would need to set the ability to see such files/folders via Folder Explorer Options. Then in the root of your C you should see a translucent like folder icon labeled Program Files\WindowsApps

  • This is a better and more complete and accurate answer than either OPs answer/comment or the accepted answer. Commented Dec 23, 2020 at 2:50
  • You also need to jump through some hoops to get permission to browse that folder.
    – OrangeDog
    Commented Jul 25, 2022 at 17:12

Pass shortcut's path to the runner (e.g. C:\Users\UserName\Desktop\AppShortcut.lnk). This worked and my problem solved. But I didn't understand where is main executable!

  • You actually DO understand where the main executable is, given that your screenshot shows that you found it. Its just that the APP model requires launching it through the framework, which is why the target is a weird string, followed by !app. Windows 10 understands this and launches the correct way to run the app. That's also why security measures are in place trying to prevent you from accessing it. Sort of anti hack attempt from Microsoft. That's all that matters.
    – LPChip
    Commented Oct 1, 2018 at 13:14
  • The main executable is probably a runner that Windows has. UWP apps aren't apps - they're instructions for the runner to execute. So there is no EXE, the shortcut just starts the runner and points it to the application. Correct me if I'm wrong, I haven't used UWP apps and this is just a guess.
    – Dev
    Commented Oct 2, 2018 at 7:35
  • My challenge was getting this to open from Firefox's file handler. This answer got me most of the way there. Firefox cannot select the *.lnk file as a handler. In addition, I created a runfile.cmd file with the contents start "C:\Users\Me\Desktop\Application.lnk" "%1"
    – maxwellb
    Commented Feb 18, 2020 at 15:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .