0

My question is about Microsoft Word version 2016, but I am open to a solution on other versions or even a workaround.

For my own purposes, I would like to be able to use two distinct tables in two independent columns.  I looked all over the place, but I couldn't find a satisfying solution. Let me explain the issue:

  • step 1: I create a "continuous" section break within a page.
  • step 2: In the new section (below the continuous section break) I use the two-column mode.
  • step 3: I create a first table in the first column.
  • step 4: Just after this table I insert a column break.
  • step 5: I insert a second table in the second column.
  • step 6: I create a "continuous" section break to complete the section.

The result is almost perfect, but Word inserts a paragraph symbol that causes a line break before the second table. So the two tables are not aligned. I could play with line breaks to align the tables, but this results in an unwanted loss of space.

To be more explicit, here is what it gives in images (look at the highlighted paragraph symbol):

immediately after creation: tables not aligned

If I try to remove this paragraph symbol, Word removes the column break too and the two tables are merged, like in the screenshot below:

deleting the (empty) paragraph deletes the column break

If I remove the table 2, the paragraph symbol is removed but the column break is kept:

removing the second table removes the second table

Of course I could use only one table with two columns but it is not my goal here.

Edit related to the answers :

@Reddy Lutonadio

To better explain what I call an unwanted loss of space, here is a series of four screenshots, with an example of the use of two columns with and without tables. For each example, there is a screenshot in edit mode, and another in print mode. To make this clear, I turned on the border shadows on the paragraphs involved in the loss of space (vertical). It can be clearly seen that the tableless version takes less vertical space when printed, for the same text length : image link - edit mode image link - print mode

I'm aware of there is also a vertical space loss at the bottom, but the thing that seemed strange to me was that Word places an empty paragraph before the second table. We can also notice that the border shadows are applied to the column jump according to those belonging to this empty paragraph. This style is visible when printing. It seems contradictory to be able to apply a style on a non-printable character.

@Scott

In order of your point :

1) Yes, this may be necessary to save vertical space for documents (often short) that have to respect a maximum number of pages.

2) I tried it, it works pretty fine :

image link I was even able to set the paragraph size to 0.7 pts, by selecting the "exactly" option in paragraph line spacing. Thank you for this workaround, I think it meets the initial need for this question.

3) Not very reliable because, as you said, the results depend on the amount of text in the first column. I have tested it a few and this way seems difficult to control the results.

With your two complementary answers I am able to solve my problem on my own, thank you very much.

0

Put the cursor right before where you type "Table 1" in Table 1, then insert a column break. The two tables will be aligned.

enter image description here

  • I tried this before and I'm ok with that, this solution fix alignment of tables. But as you can see this trick leads to an unwanted loss of space and, it is that I want to avoid. – Parian Oct 1 '18 at 18:52
  • Can you explain what you mean by unwanted loss of space? – Reddy Lutonadio Oct 1 '18 at 18:58
  • I put my explanation as an edit of the initial post. – Parian Oct 1 '18 at 21:57
0
  • You say “I could play with line breaks to align the tables, but this results in an unwanted loss of space.”  Am I misunderstanding something? One blank line (i.e., empty paragraph) before Table 1 will align the tables.  Is one blank line so terrible?
  • You could change the blank line (i.e., empty paragraph) before Table 2 to be 1 pt. in size.  This will make it almost invisible, and cause the tables to be almost perfectly aligned.
    • If you insert a blank line (i.e., empty paragraph) before Table 1, and make it and the blank line before Table 2 be 1 pt. in size, then the tables will be perfectly aligned with very little wasted space.
  • Whether you can do this may depend on how big your tables are (i.e., how much text they contain), and how much other (non-tabular) text you have in that two-column section, but try:

    1. Create the two tables with an empty paragraph (but no column break) between them.
    2. In Table 2, format the first column of every row (except, perhaps, for the last one) as “Keep with next”.

    Example:

example document with a table in each of two columns

  • I anwsered your three points in my initial post. – Parian Oct 1 '18 at 22:50
0

With the help of Reddy Lutonadio and Scott, here is the quick solution to avoid vertical space loss when you want to use two distinct tables in a two columns section : (For increased visibility, turn on the display of non-printable characters.)

Initial position :

image link

  1. Create a new section | Click on "Layout">"Break">"Continuous".
  2. Select two column mode | Click on "Layout">"Column">"Two".
  3. Insert a break column | Click on "Layout">"Break">"Column".
  4. End the section | Same action as step 1.

Now you should see the same section structure like the screenshot below :

image link

  1. Put an empty paragraph inside the first column | Click just before the column break then press enter

  2. Insert a table inside the first column | Click on "Insert">"Tables" then click on the target table size.

  3. Insert a table inside the second column | Same action as the step 6.

Now you should see the two tables side by side, perfectly aligned like the screenshot below :

image link

  1. Reduce the size of top empty paragraph for both column | Click on the empty paragraph then click on "Paragraph settings">"Indents and spacing">"Spacing">"Line spacing" then select "Exactly" then choose the minimal size ("At: 0,7 pts"). Remove spacing before and after too.
  2. Reduce the size of bottom break for both column | Wether for the section or column break, click on the break then apply the same paragraph settings as the step 9.

You're finished and you should see the result like the screenshot below :

image link

Note: Another way is to use a two column section without tables (if it is not required). In this case you just need to follow from the step 1 to the step 4.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.