I've tried researching various SuperUser forum posts and even a blog post (https://blog.superuser.com/2011/04/25/virtualbox-and-networking-how-you-do-it/), but none of the questions seem to resolve my specific situation, and am hoping someone can help me out here.

I'm running the latest build of Oracle Linux Server 7, with the Gnome GUI installed, inside VMware Workstation Player 14 initially and now the latest VirtualBox (VMware Workstation Player 14 does not have Virtual Network Editor attached, which I initially thought I may need). I've got the Apache web server up and running in the VM/guest, for which I can reach the test page in my Chrome web browser on my host PC (Windows 10 Home). Local IP of my VM/guest in VirtualBox (VMware is still installed, but not running - I've ported *.vmk file to an *.ovf file and imported into VirtualBox, and it's running smoothly there now) is Local IP of my host PC is and my router is I won't post my external IP address here, for obvious reasons of which I'm sure you're all aware.

The blog post said to try pinging your host PC ( in this case) from your VM/guest, but it said "network unreachable". I just tried pinging my VM/guest with success. I added "Virtual Machine Monitoring" and "VMware" as permitted apps to bypass Windows Defender firewall, but still no go accessing my Apache web server via my external IP address.

Any ideas!?


Screenshot of Oracle Linux 7 in VirtualBox VM on Windows 10 Home host PC

Cheers, Doug

  • For what it's worth, I just tried disabling my Windows Defender firewall on my host PC for 'domain,' 'private,' and 'public' networks, with NO success. I don't know if it's something I need to do my D-Link "routing" information, but since that post above, as you can see from the screenshot, I've enabled a 'bridged connection' and 'NAT connection'. The NAT connection now has an internal IP assigned by my router..I can now ping the guest VM from the host PC, but still can only access the Apache web server from the internal IP. Make sense!? – Doug Mehus Oct 2 '18 at 1:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.