0

I recently installed Ubuntu 18.04 Server on a pair of drives in RAID1, which I set up using the installer. Previously, I was able to boot into the RAID install without any problem (even though it never showed in BIOS).

Trouble began after I set up some other disks on my system, making two additional RAID1 arrays and splitting one of those into two partitions. After reboot, I just boot to a black screen. I suspect that the system is trying to boot onto another disk on the system, but I don't have anything else that should be bootable. Only one drive does show in BIOS, which is an NVMe that is not included in any of the arrays. All the non-OS drives have newly made partition tables and not partitions shown in Gparted except for the ones I created. I am sure I did not change anything on the bootable RAID volume.

When I boot using a Gparted USB, my RAID devices are there and partitioned as expected.

I can think of two general ways around this:

Get the RAID device (or one of the mirrors within it) to show in the BIOS. Get the system to do what it did before, which was to bypass all the drives and just boot from the only available boot volume, my RAID drives. Any suggestions about how to troubleshoot this would be welcome.

Other info:

  1. My motherboard is an ASUS X399 Taichi

  2. I have tried both AHCI and RAID mode in my Bios

  3. One of the newly created raid arrays shows as just regular disks in gparted. I am fairly sure that MDADM said they had successfully been made into an array when I first created them. These are 2x 8tb HDDs.

  4. The other new array, a pair of Evo 970 NVMes does show in Gparted

  5. To reiterate, none of the above drives shows in the boot menu, the only device that does is a blank ext4 formatted nvme not in raid.

0

I fixed it by going into the boot menu and changing boot priorities and disabling the NVme that was showing in BIOS before. That allowed the drives that I wanted to boot from to appear in the BIOS. Not clear on why the drives showed in the boot menu but not the BIOS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.