1

I have my ISP router that I cant do much with e.g. VPN or Smart DNS. I would like to set up a second router to for this.

This is how it is connected. ISP Router (192.168.0.1) LAN to DD-WRT router (192.168.1.1) WAN port

When I connect to the DD-WRT I dont get a internet connection. What am I missing ?

  • 2
    You are missing lots of information. For a start, what are the models of the two routers? I'm sure someone else will come along and ask for more ... – DavidPostill Oct 3 '18 at 17:20
  • An educated guess would be re-use if the same subnet or issues with default gateways. What are the IP addresses, netmasks and gateways of each device. Also, are you doing double NAT, and what interface / IP are you testing from - it could be that the ISP router needs a route back to the dd-wrt one. – davidgo Oct 3 '18 at 19:24
1

There are two ways to do this.

  1. (Cascading) The Second routers WAN connected to the first routers LAN port. For this to work, the second router must have it's WAN address inside of the first routers subnet range. I.e if router-1 is 192.168.0.1 router-2's WAN address should be something like 192.168.0.2. this isn't great way of doing this, you will have a double NAT/firewall when connecting or trying to port-forward to the second routers subnet.

  2. (Bridging) The second routers WAN interface disabled, with a LAN address of 192.168.0.254. connect the two LAN-port <----> LAN-port. disable the DHCP server, use the drop-down to put it in DHCP forwarding mode pointing at router-1 (192.168.0.1) in the setup tab. Disable the SPI firewall under the security tab. If you choose the same network name (SSID) as the first with the same key, but on non-overlapping channels they will roam seamlessly between the two wireless routers. Bridging has the advantage of not having to double port forward as you would have to if you cascaded the two.

  • Hello and thank you for your comment. I am right in say if I did a bridging wouldn't be about the use the Router 2 as a VPN/Smart DNS? – Stephen Mottershead Oct 3 '18 at 19:33
  • We may have a language barrier, if I understand you correctly... Bridging is what you would want if you want to host the VPN. – Tim_Stewart Oct 3 '18 at 19:49
  • I need to change the IP of the second router for 192.168.1.1 to 192.168.2.1. This has fixed the internet problem for the second router. . – Stephen Mottershead Oct 4 '18 at 10:25
  • That's not going to work out well for you... That is a cascading configuration, you will have problems with it configured this way when you go to setup the VPN. – Tim_Stewart Oct 4 '18 at 12:16
  • I have just set up a VPN and it works fine. Why would I a have problem ? – Stephen Mottershead Oct 5 '18 at 13:12
-1

After a lot of messing about last night I have sorted out the problem and I have now got internet on the other router.

My ISP (SKY) Router is set to 192.168.0.1 and I left that as default. The DD-WRT router was default set to 192.168.1.1 and that looks like it should of worked, but it didn't.

I need to set the IP to 192.168.2.1 for it start working. I am not sure why this is but it is now all working.

Thanks for the help :)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.