0

I am trying create iso (supporting uefi) as follows,

genisoimage \
    -follow-links \
    -o $dir/$iso_name \
    -b isolinux.bin \
    -c boot.cat \
    -no-emul-boot \
    -eltorito-alt-boot \
    -eltorito-boot images/efiboot.img \
    -V 'CENTOS 7' \
    -boot-load-size 4 \
    -boot-info-table\
     -R -J -v -T \
    $ISOLINUX_DIR/

But am facing the error as below,

Size of boot image is 48 sectors -> No emulation
Size of boot image is 4 sectors -> mkisofs: Error - boot image '/net/.../CentOS/isolinux/images/efiboot.img' has not an allowable size.

0

You did not mark the second boot image as being for EFI rather than x86 BIOS. Depending on the variant of genisoimage, this may be done by option "-e" instead of "-eltorito-boot". It should be accompanied by an own occurence of option "-no-emul-boot".

Options "-boot-load-size 4 -boot-info-table" apply to the BIOS image "isolinux.bin" and need to be moved before the separator "-eltorito-alt-boot".

Try


genisoimage \
    -follow-links \
    -o $dir/$iso_name \
    -b isolinux.bin \
    -c boot.cat \
    -no-emul-boot \
    -boot-load-size 4 \
    -boot-info-table \
    -eltorito-alt-boot \
    -e images/efiboot.img \
    -no-emul-boot \
    -V 'CENTOS 7' \
    -R -J -v -T \
    $ISOLINUX_DIR/

If your genisoimage does not offer option -e, try instead:


xorriso -as mkisofs \
    ...above.options...

(Option -T will be ignored.)

Have a nice day :)

Thomas

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.