4

I upgraded my internal hard drive which contained windows 10 pro, I wanted to keep the old drive as an external USB booting drive (connected through SATA USB adaptor ), now when I try to boot from it, I see the windows logo and after a few seconds it gives me the error "inaccessible booting device" .

Given that, The drive works fine as an internal drive. As USB drive I am able to boot to the safe mode.

Do I need to change anything in the setup (maybe in the registry) to make it USB bootable as well?

Thanks in advance.

3 Answers 3

5

set this value in the registry HKLM/SYSTEM/HardwareConfig/{..guid..}/BootDriverFlags = 0x14

I'm pretty sure this is all tools like FlashBoot and WinToUSB are doing

4
  • Thank you. You're dead right! BootDriverFlags = 0x14 solve my problem of manual cloning a HDD Windows instance to an external USB-SSD. Got INACCESSIBLE_BOOT_DEVICE.
    – Jimm Chen
    Feb 20, 2022 at 17:32
  • Not sure how to apply this suggestion. I can't boot the drive, so I can't modify the registry of the Windows installation on that drive. Mar 25, 2022 at 9:52
  • 2
    @RayWoodcock you can use the recovery console (see winhelponline.com/blog/edit-registry-offline-windows-re)
    – gordy
    Mar 25, 2022 at 17:43
  • 1
    Using the recovery console I can view and edit the value, but I'm finding that it keeps being reset to 0x1c after the next reboot (and changing it to 0x14 doesn't fix the issue, even if I continue to Windows 11 without a reboot).
    – MikeBeaton
    Apr 25, 2023 at 10:54
0

Since your old HDD is in a new location hardware-wise, I would suggest clearing the MountedDevices subkeys from the registry on your old HDD.

To do this:

  1. boot into Windows on your new internal HDD (with the old drive attached via USB) and start the Registry Editor (Win+R > regedit).

  2. Select HKEY_LOCAL_MACHINE, then from the menu bar, select File > Load Hive and use the file browser to navigate to your USB HDD to the file "\Windows\System32\config\SYSTEM".

  3. On the "Load Hive" dialog, give it an easy to remember key name so you don't confuse it with the keys on your new HDD (e.g. "tempsys")

  4. go to the "MountedDevices" subfolder in the tempsys key and in the right panel, delete all the subkeys of the Type "REG_BINARY" (you can leave the (Default REG_SZ) subkey). These are the drive mappings from when your old drive was internal.

  5. back in the left tree panel, select "tempsys" and in the menu bar select File > Unload Hive.

  6. Restart your PC and try to reboot from the USB HDD in normal mode.

If it works, Windows will automatically rebuild the MountedDevices subkeys on your old HDD from its' new location on boot.

EDIT: You also need to update the Windows Boot Configuration Data (BCD) on your old USB hdd. I found this link on ServerFault which explains how to edit the BCD on another disk besides the disk you boot from. You'll want to do this from Windows on your new HDD, but be careful you don't edit the BCD on the new disk by accident. There are also links to GUI BCD editors if you're more comfortable with those instead of the Windows CLI bcdedit.

3
  • I tried your proposal but unfortunately nothing changed . Oct 5, 2018 at 22:46
  • Sorry that didn't solve your problem. That technique has worked for me in the past, but only moving OS partitions to other disks or other parts of the disk that were connected to the SATA bus, not USB. When I get some free time I'll see if I can find a solution that works or perhaps someone else can chime in to help.
    – Blaelph
    Oct 6, 2018 at 0:38
  • If you're still here @Blaelph, what aspect of BCD exactly do you need to update? I can see nothing obvious that needs changing... Thx!
    – MikeBeaton
    Apr 25, 2023 at 11:11
0

Well I am feeling good to find a solution for my problem.

I used a tool called wintousb which you can get for free from the link below

https://www.easyuefi.com/wintousb/

1- launch the tool and form the tools menue choose "Windows to go conversion!" 2- Select your drive where the normal windows was installed. 3- Few seconds and you would be able to boot to your portable windows.

If the answer was helpfull for you please rate it!

Snapshot from the tool

1
  • 1
    Well, the Tools menu has changed to a little drop-down arrow, but the option is still there. However it didn't work for me, still the same 'INACCESSIBLE_BOOT_DEVICE' error message... :-(
    – MikeBeaton
    Apr 25, 2023 at 11:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .