8

I have a laptop with combo audio jack, which means whenever I plug an earbud that has a mic, the machine will automatically detect that mic and disable the laptop's internal mic. That's not good because my laptop's mic works better for some reason. The earbud's mic is noisy on the PC despite it working great on my phone; this happens with other earbuds too. I don't know why, I guess it has something to do with earthing/grounding but that's not the point here. Anyways, to achieve my desired setting I need to have this pop-up enabled for whenever I connect an audio device it asks me what it is.

Dialog picture

Here I can select to ignore the earbud's mic, but this is not a great choice because every time I plug it in, that thing pops up, which is not good while gaming, for example. Now, yes, I can disable this pop up, but that setting is never saved, which means whenever I plug the earbud in, the system will disable my laptop's mic.

Question is: Is there any kind of registry trick, or maybe some auto hotkey script that can solve this problem?

5

I had the same problem for over a year. Gosh, how many different things I tried, don't even get me started. Finally, today is the day I managed to resolve it.

Recently, there was an update (bet it was earlier, but I didn't bother to update my Windows), and the application Waves MaxxAudio Pro application has either been updated or whatever happened to it, but when I plugged in my headset, it showed the popup. Nothing new here, I had the same popup before, just didn't select what I needed. As you should see on the screenshot, I selected 'Headset' and 'Over-ear'. Right after that, the recording switched from my laptop mic to the mic on the headset. Although in the recording section of the sound app it does not show any new devices and I have only one mini jack slot for both mic and headphones in my laptop.

Hope it helps

application name and popup in task manager

2

In Windows, You can set your internal laptop mic as the Default Recording device this way:

  1. Navigate to Control Panel > Hardware and Sound > Sound.

  2. Select the Recording tab. You should see your internal mic as the default recording device.

  3. Plug in your earbud/mic headset, then you should see the headset device appear and it will change to the default device.

  4. With the headset still plugged in, select the internal mic device and click "Set Default". You can also set the internal mic to Default Communications Device with the drop down arrow in the Set Default button for things like Skype if you wish.

  5. Test that the internal mic stays the default device by unplugging the headset and plugging it back in.

  6. If the internal mic stays default as intended, you can disable the pop-up dialog asking you what kind of device the headset is. Depending on who manufactured your sound hardware, you should be able to do this in the sound manager app by that company. See this example.

1

The solution in this forum worked for me.

https://forums.tomshardware.com/threads/disable-headphone-microphone-to-use-build-in-laptop-microphone.1816970/

Open up the Realtek HD Audio Manager application (I found it through search) and then select Advanced device settings in the top right corner. In the pop up choose Multi-stream mode and that should then split the mic into microphone array and external mic.*

0

Go to HD Audio Manager and you should see on the right side of the window an analog bar with a black dot on it. Press it and then a little window will appear then just try all of the options you see until you find your headset. I found out just a minute ago.

0

Had a similar issue. As it turns out, it's the difference between "headphones" (speakers only) and "headset" (speakers and mic). After you plug in your headset, and the MaxxAudioPro dialogue box appears, selecting "headphones" will send audio to your headset speakers. The mic settings will remain unchanged, ie you'll still use the pc's internal mic. Selecting "headset" will send audio to your headset AND will prioritize your headset's mic.

0

Here's a solution:

  1. Go to Realtek audio manager
  2. Turn on Multistreaming
  3. Go to control panel, search for sound and click it
  4. Go to the recordings tab, select microphone array, and set as default.

This will turn off the mic on the earphone, enabling the laptop's mic.

0

This did the trick for me: Open up the Realtek HD Audio Manager application (I found it through search) and then select Advanced device settings in the top right corner. In the pop up choose Multi-stream mode and that should then split the mic into microphone array and external mic.

Then go to your windows audio settings and there should now be two separate mic input alternatives, one for the built-in and one for your input headphones mic.

Found here: https://forums.tomshardware.com/threads/disable-headphone-microphone-to-use-build-in-laptop-microphone.1816970/

1
  • Welcome to Super User! There are other answers that provide the OP's question, and they were posted some time ago. When posting an answer (see: How to Answer), please make sure you add a new solution. Do not copy answers or substantial parts from other users. Dec 10 '20 at 18:12
0

If you have Realtek Audio Console:

  1. Open it
  2. Open Device advansed settings
  3. Connector Retasking change to Headphone

So, it will not detect Jack as Microphone.

New contributor
Hilarius Khaliullin is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.