2

I am using Windows 10, 64-bit, Version 1803, Build 17134.320.

When I try to set a new "Default App" for a certain file type or protocol (eg: .txt files) to be opened in, Windows does not save the setting and keeps resetting it to the system default.

I have tried multiple ways of applying the new settings:

  1. Right click the file -> Properties -> Opens With -> Change
  2. Right click the file -> Open With -> Choose another app -> Always use this app to open .txt files
  3. PC Settings -> Apps -> Default Apps -> Choose default apps by file type/protocol

None are able to apply a new default app to a filetype.

When I try to change the association using option 3, the "SystemSettings.exe" application hangs for 5 seconds and then simply resets the options back to the system default.

I even contacted the Microsoft support and had two supporters remotely connected in order to fix the issue. Even they had no clue what causes it.

  • Does this happen if you boot only in Windows Safe mode? – harrymc Oct 7 '18 at 18:25
  • I tried to do a system restore, now it works for me. I think there might be a bug in the latest windows update ? (I got it to work in 17134.285). – Emil Oct 12 '18 at 18:10
  • Possible duplicate of SSMS wont give up file associations – Ramhound Nov 24 '18 at 14:29

protected by Community Nov 24 '18 at 16:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.