3

I recently tried to install ReactOS, and did so by:

  • Downloading the .iso from SourceForge.
  • Writing it to a USB drive using the "Make bootable USB stick" option on the Nemo file manager (for Linux). This created a 1.9GiB iso9660 partition with all the ReactOS files on it.
  • Booting from the USB (I could only boot in BIOS compatibility mode). I get a Windows 2000-like loading screen that says:

Loading ReactOS setup...

Loading NTSOKRNL.EXE...

Loading HAL.DLL...

Loading Setup...

Then, I get the black screen of death - no cursor and no disk activity. I tried several times (and waiting), but still got the same black screen of death.

I tried again, by making a blank FAT32 partition and copying ll the files from the ISO onto it. This time, it wan't even detected as being bootable.

What can I do to install ReactOS?

I have an HP 10-e010nr laptop (HP 10 TS Notebook PC).

closed as off-topic by Evan Carroll, Twisty Impersonator, fixer1234, Toto, music2myear Nov 16 '18 at 0:38

  • This question does not appear to be about computer software or computer hardware within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Off topic, I'm shocked Microsoft isn't suing the creators of ReactOS for copyright and likeness infringement. – Jesse P. Oct 7 '18 at 1:48
  • 1
    ReactOS is meant for experimenting with inside a VM. I wouldn't be surprised if it didn't work on actual hardware. – dsstorefile1 Oct 7 '18 at 4:46
  • Have you tried burning it to a CD (the intended output for an iso image) and booting that? – Mokubai Oct 7 '18 at 7:02
  • 3
    ReactOS is special-cased on SuperUser and offtopic. – Evan Carroll Nov 13 '18 at 18:44
  • 3
    ReactOS isn't a special case, and not every question related to ReactOS is automatically off-topic. However, it's developmental software, and questions about developmental issues (e.g., problems that would be fixed or features that would be completed during development) are generally off-topic, which is the case here. – fixer1234 Nov 15 '18 at 11:31
2

USB boot is not supported yet as explained here:

Warning: With current versions of ReactOS, USB support is NOT advanced enough to successfully boot, and ReactOS will crash when it begins loading system USB drivers. See e.g. CORE-7826. The following details for older versions are left here for historical reference and for use in the future when this feature becomes supported again.

See this site for the experimental builds.

You should use PXE-network boot or PXE-network installation instead.

  • 5
    Hi there. I edited this question to add the “meat” of the answer which is on the ReactOS page you linked to that clearly states USB boot is not possible yet. You should always provide clear context for an answer here to avoid having people to going to external links and—besides—external links can go dead without notice even on well known projects. – JakeGould Oct 8 '18 at 22:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.