I tried installing fedora on my laptop which had Windows 7 pre installed I wanted to have a dual boot system boot things were not clear so I could not do it. I then later tried to proceed only with Fedora 28 on my laptop so that I can work but even during installation of fedora 28 from live USB I got errors. At the point to select installation destination things go wrong. As far as I know I need to create three partitions

  1. Boot /boot 100mb
  2. Swap 4GB
  3. Root / 72 GB (the C drive of my Windows 7 installation)

so this is what I tried to do also but I get errors.

disk sda already reached maximum allowed number of primary partitions

There is C drive,E: drive and F: drive in my disk. Now I want to install Fedora in C drive how to do this any video on youtube which makes things clear I could not search. Here is a screenshot

Here are more screenshots that may make things more clear

  • Guessing you've got an MBR and not GPT disk, and can barely see that you've probably got 3 primary partitions and what looks like an extended partition with one partition in it - should be able to make dozens more partitions inside the extended partition, not sure why you can't, unless there's just no space and the installer's giving weird errors? – Xen2050 Oct 7 '18 at 7:53

I can only guess that the installation is not clever enough to see that after the deletion of the NTFS partition you will have one free partition slot.

I think you will need to do this in stages : First delete the partition and commit the disk changes, then reboot and install Fedora on the liberated space.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.