1

I'm using Windows 10 Anniversary Update and recently the Windows search feature has stopped working. I think it was due to some copying / cutting around some of the file in my AppData or something (not completely sure about the cause, just guessing)

Here is the result when I try to search for Control panel:

screenshot of Windows search returning no results

I have tried every single thing I can find on the Web, including restarting Cortana/Windows search service, rebuilding search index ... but nothing could help. Any idea how to solve this ?

  • Workaround: use a third-party tool such as DocFetcher (which can index some document types that Windows Search can't). – DrMoishe Pippik Oct 7 '18 at 23:54
  • I indeed tried to use "Everything" and somehow for searching files it's even better than Windows search. But I'd still prefer if Windows search is restored. – ramcrys Oct 8 '18 at 8:04
  • Use the command to re-register Cortana. 1. Open Windows PowerShell,run as Administrator. 2. Type Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} 3. Click Enter. – Daisy Zhou Oct 9 '18 at 14:28
  • Still doesn't work ... – ramcrys Oct 9 '18 at 15:49
0

After a rather long time, I decided to fix it in the brute-force way (and it works !) by creating a new user account, copying some important apps config over, then starting everything anew there.

Seems silly, but it works ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.