1

I have a super annoying issue with a Brother MFC-L2740DW where any time I print a document that contains the characters fi, the page comes out with ¿ instead.

i found this guy with the same problem but there is no resolution to this unrealistically irritating problem.

Does anyone happen to know how I can resolve this?

The document I am printing is a pdf and I'm printing it from Adobe Acrobat Reader DC

1

Most probably this is due to a typographic ligature, characters "fi" being combined to a single character "fi", in connection with incorrect encoding/defects in the font embedded into the PDF. There might be some defects in "ff" character sequences, too.

You can check for ligatures by trying to mouse-select single characters in your PDF reader... if you are unable to select just "f" (or "i"), and the selection "jumps" at this point, you have a strong indication there is neither "f" nor "i" present, but the combined character.

If you are the creator of the document, try to turn off ligatures in your word processor, and print/export to PDF again. (If that doesn't work, try to delete and re-type an erroneous "fi"; maybe the word processor will not remove ligatures already present in the document when turning off this feature.)

If you just got a PDF from somewhere, you are out of luck; the PDF has been created in defective way.

|improve this answer|||||
0

You need to change the character encoding on the PDF file, which you cannot do if you are not its creator.

To convert the file to another format PDF, you may try the strange method of printing it to ... a PDF printer. This may create another PDF file that may not suffer from this problem.

|improve this answer|||||
0

This sounds an issue with the font not being embedded properly or even at all.

If you are the creator of the PDF, make sure that you embed and subset all fonts. If that does not provide the desired effect, follow jvb's advice and deselect the use of ligatures.

If you are not the creator of the PDF, go to the advanced printing options in the Acrobat print dialog and check "print as image". In this case, it will be Acrobat rendering, and apparently, it can do it properly.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.