0

When I run ubuntu1804.exe for having "Linux distros for WSL", I receive this:

The Windows Subsystem for Linux optional component is not enabled. Please enable it and try again.
See https://aka.ms/wslinstall for details.
Press any key to continue...

But, it is enabled on my Windows:

PS C:\WINDOWS\system32> Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux


Path          :
Online        : True
RestartNeeded : False

And here is the screenshot of optional features window:

Image of Optional feature

What sould I do to solve this? would appreciate any assistance.

P.S: I tried "disabling WSL, rebooting, Enabling WSL, rebooting" but not working.

  • Which Windows 10 build you're using? – Biswapriyo Oct 8 '18 at 13:02
  • What is ubuntu1804.exe? I start WSL by typing bash in a Windows command prompt. – simlev Oct 8 '18 at 13:08
  • Oh, you want to start a GUI. Which Desktop Environment? How did you set it up? – simlev Oct 8 '18 at 13:14
  • 3
    Windows Subsystem for Linux has not been in Beta for over a year (1703). You should upgrade to 1803 then install the Ubuntu WSL instance from the Windows Store instead of using the legacy instance your currently using. Windows 10 Version 1607 is not compatible with the instance your trying to use. – Ramhound Oct 8 '18 at 13:51
0

My windows version and also Windows Subsystem version is OLD so it is not compatible. It must be upgraded.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.