2

When I do this command:

mklink /D "C:\Users\user\Desktop\MyDocs\VSCode" "C:\Users\user\.vscode"

I get the error : "The system cannot find the path specified."

I run cmd as admin.
I am able to create Symbolic Link Directory for others folders.
I have followed the recommandation on this question.
I am able to move to the .vscode with cd C:\Users\user\.vscode and to list its content with dir.

C:\Users\user\.vscodeis a hidden folder.
I am on Windows 10.

  • Question: ls is not a Windows command, so how are you doing the mklink? – harrymc Oct 9 '18 at 11:15
  • ls worked for me on a regular (not admin) cmd (maybe because I installed git repo : superuser.com/questions/1248999/…). I am doing the mklink by copying the command in my question in a cmd started as admin. (I am on windows 10) – MagTun Oct 9 '18 at 11:21
  • I change ls to dir to avoid the confusion. – MagTun Oct 9 '18 at 11:31
  • 1
    Try to first cd "C:\Users\user\Desktop\MyDocs\" and then "mklink /D VSCode "C:\Users\user\.vscode". If that fails, I haven't found any reason for it, but you might try to unhide .vscode`. – harrymc Oct 9 '18 at 12:18
  • Yeah, it's working. Post it as an answer, I will upvote it. – MagTun Oct 9 '18 at 12:25
2

This might work better :

cd "C:\Users\user\Desktop\MyDocs\"
mklink /D VSCode "C:\Users\user\.vscode"
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.