I have an Office 365 account set up with two email accounts under one profile in Mail 32 in control panel.

Every time Outlook 2016 is open it prompts for just one of the accounts passwords, I enter the password in and it is just a never-ending loop.

I cancel that menu and I am able to send and receive email on both accounts. I left click on the "Need password icon" at the bottom right and I can clear the message and it will just say "Connected to Microsoft Exchange".

Additionally, that clears it or sending and receiving email. Seems like a false positive, and this is also a brand new set up. Lots of emails in both accounts, but these accounts are newly added to the Outlook. Is there any way around this?

  • Can you add a sceenshot of the error message and your accounts setup? Giving your question some form besides that of one long paragraph will make it easier to read. – harrymc Oct 9 '18 at 13:45
  • @harrymc there is no error message, just a never ending loop after entering the password in. – LeGreen95 Oct 9 '18 at 13:47
  • Sorry, I meant password prompt (to be sure it's the normal one). – harrymc Oct 9 '18 at 13:48
  • 1
    Try this: Open Control Panel -> Credential Manager and remove all passwords related to Office or Office 365. – Steve Fan Oct 10 '18 at 3:16
  • @SteveFan you were correct, that was what it was required to do. – LeGreen95 Oct 11 '18 at 18:01

Just got the same problem with three different clients: Mailflow working without a problem, but password prompt always pops up again... it seems to be a problem with an Exchange-/Windows-Update, not sure...

Outlook tries to connect to outlook.office365.com even the account isn't hosted there (see credential manager). This registry entry solved the problem:

  • I've also see this issue in the case where Exchange is not hosted at O365, but elsewhere. Did this reg entry work after Outlook 2016 got an update in Oct 2018 (with the new icons) and became just "Outlook" ? – Ian W Nov 1 '18 at 14:15

Please make sure you dont have any add ins which is trying to authenticate to the server and failing.


I suffered the same problem & spent a while searching for a solution. Some of the things I did where:

It then dawned on me that MS recently made a push for 'Multi-factor' authentication, i.e better user security, which think many of us may agree with is not a bad idea. I had activated this function some weeks ago. Unfortunately, this W/E I my mobile phone died a death and the authentication service no longer could reach the app for secondary authentication. Consequently, I kept receiving the authentication prompt.

The solution I applied (which may help some of you guys out there & save you some time :) was

  • Log into the Office 365 admin Center
  • Navigate to Users | Active users & select the 'Multi-factor authentication' tab a the top
  • Find the effected user & disable the 'Multi-factor authentication status'
  • Wait 5 minute, pray & hopefully it's solved

After which I could re-register the account I had happily deleted & reach the exchange server

This may not be the solution for all, but perhaps for some.

Good luck,


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.