2

When I use a signature in Outlook email, spell check gets disabled for parts of my document. I believe this occurs when I am editing the email and enter text into lines that were originally part of the signature. Is there a way to avoid this? Can I set my signature to have spell check enabled?

I am using Office 365 and have Outlook 2016 (16.0.9126.2282) 32-bit, but I know this is an old problem and has affected me for years.

Here are steps to reproduce:

  1. create a signature in Outlook enter image description here

  2. Write your email message and enter text in the line that was part of the signature. Notice that even though the text is not spelled correctly, Outlook does not highlight it as a spelling error. enter image description here

  3. Select the new text added. Go to Review->Language->set proofing language. Notice that the "do not check spelling" option is checked. enter image description here

  4. Clear that check box and click OK. Notice now that spell check is working correcltyenter image description here

  • 1
    (Too?) simple advice : Start the signature with two dashes and a space ("-- ") above the actual signature (RFC recommended). This will help you see where the signature begins and prevent typing in the signature area. – harrymc Oct 9 '18 at 15:58
  • That is petty good advice. Thanks. I think the best work around for me is simply: don't have a blank line at the top of the signature. Because my signature usually includes a blank line for formatting, I end up editing text in the signature area. If I don't include that blank line, this will be less likely to affect me. (but I do think it is an issue and Microsoft should address it). – Michael Levy Oct 11 '18 at 13:05
  • I made an answer of it. – harrymc Oct 11 '18 at 15:03
2

Very simple-minded advice :

Start the signature with two dashes and a space ("-- ") above the actual signature, as is actually recommended in the standard RFC and supported by many email clients.

This will help you see where the signature begins and prevent typing in the signature area, and also make it clear to the email client where is the signature. Some email clients will display the signature a bit differently if they know where it starts.

| improve this answer | |
  • Yes. This behavior seems to be by design and has been around for a while. Yuki Sun pointed out this article which documents the same issue to versions going back to 2007. It also suggests the "-- " separator. For now, I removed the blank line from the top of my signature. That seems to help. If needed, I'll add the "-- ", but that seems so old school, like mailx at the command line. slipstick.com/outlook/email/outlook-signatures-spell-check – Michael Levy Oct 12 '18 at 13:14
0

(Sorry that this may not be a solid answer. I meant to add a comment but comment doesn't allow inserting images :( ) I checked my Outlook for Office 365(Version 1809) and Outlook 2016 (MSI edition) but didn't see the checkbox of "Do not check for spelling and grammar" selected. I did notice that the spellchecking didn't occur when the typing as what is shown in your second image. But it seems to me that it's the same when there is no signature or even in Word:

enter image description here

However, if I press Enter after finishing typing the wrongly spelled text, the auto spellchecking can work as expected:

enter image description here

Not sure if this is an expected behavior or a known issue. But in order to prevent messages being sent out with wrong spelling text, it is suggested to select the checkbox of Always check spelling before sending: enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.