0

Preface:

We just moved houses, and in an effort to modernise the new house, we've begun to pull CAT7 cables through, from the router to a switch, and then on to perhaps another switch and an access point. I have a 500/500 connection with my ISP (https://www.speedtest.net/result/a/4323520476).

The problem:

I made a diagram here (not enough rep to post directly):

enter image description here

I have a gigabit access point, and 2 gigabit switches (netgear GS105 & TP-Link TL-SG108). Both switches get a 1000 mbps connection to the router over the first CAT7 cable, but any device I hook up to the switch only gets 100 mbps over CAT7 (the blue line). When I use a cat6 cable from the switch to the AP I get gigabit. The strange thing is, that when I use the 100mbps CAT7 cable to directly connect the AP to the router, I get 1000mbps!

Do both my switches somehow throttle network speeds when using CAT7?

  • The access point connect by CAT6, this a different access point, or a different access point? – Ramhound Oct 10 '18 at 10:17
  • 3
    I'd guess that the CAT7 cable is incorrectly terminated or faulty. Have you made sure that all pairs are correctly connected? – Mokubai Oct 10 '18 at 10:41
  • @Mokubai Thats the most likely. However, it could also be a faulty port on either device. Or it could simply be autodetecting incorrectly. – Keltari Oct 10 '18 at 10:53
  • @Mokubai I've tried it with 2 factory-ready CAT7 cables and with 1 different CAT7 cable that ive terminated myself. In all cases will it switch to 100 mbit. All access points in this diagram are the same one, this just shows all different combinations i've tried. The blue cables are also the same cable, just once plugged into the router and one into the switch. – Bart Zweers Oct 10 '18 at 12:48
  • @Mokubai Incorrect mapping of pins to pairs, pins to pins, or a pin that doesn't go through is the most likely explanation for this problem. – David Schwartz Oct 10 '18 at 15:37
2

Most likely, you have an analog problem: A less-than-perfect connection on one of the sockets or plugs on the blue CAT7 cable, that puts it outside the specs for Gigabit Ethernet.

Different manufacturers design different levels of resilience for out-of-specs cables into their products. So it is easily possible, that your router can still communicate on a gigabit level, while the switches fall back to the less demanding 100MBit.

By accident I have been in a very similar situation a few days ago: It was 100Mbit with a Zyxel switch and no connection at all with a HP switch. Recrimping the wall outlet fixed it.

  • 3
    It would be a "Physical layer" problem not a analog one, as Ethernet is all digital. :) – Tim_Stewart Oct 10 '18 at 12:20
  • I thought so too, but I've bought multiple 2m CAT7 cables that are 'factory-crimped', and I have a cat7 cable that i've terminated and crimped myself. None of them give me 1000 mbit but instead all of them revert to 100 mbit. It also takes a long time for the switch to start blinking any of its speed-LEDs, while with the cable from the router it starts blinking instantly. – Bart Zweers Oct 10 '18 at 12:44
  • 1
    @Tim_Stewart I beg to differ: On the bottom of every network, there is a layer of physical signal propagation, that is by its very nature analog: SNR and damping are analog phenomenons. – Eugen Rieck Oct 10 '18 at 13:04
  • @BartZweers This seems to make your problem different - although the slow speed negotiation points in the right direction. Would you please try a cable, where the outer signal ground (the shielding) is sure to be not connected to (and not touching) the AP-sided shielding and try switching the power supplies between the APs. This could be a variant of the "analog" variety that includes unclean ground potential. – Eugen Rieck Oct 10 '18 at 13:09
  • 1
    @EugenRieck I think the cable should be fine, because it functions perfectly normal when connected directly to the router (also the chance of 3 cables being bad...?) I now connected both a cat5 cable and a cat7 cable from and to the switch in a loop: Cat5 cable: i.imgur.com/390uOUu.jpg Cat7 cable: i.imgur.com/tgpw78T.jpg i.imgur.com/OVkyj8X.jpg Even here the switch with cat7 only manages to put through 100 mbit to itself.. – Bart Zweers Oct 10 '18 at 17:04
0

Just to answer my own question, the issue was that the CAT7 cables between the router and the switch were not terminated according to spec.

After terminating them using CAT7 specced keystones and to then use factory-crimped cables, the issue resolved and I now have full speeds.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.