3

I was reading the news on the internet when I realized that I lost the connection. Not only I was disconnected from the wifi network, but I can't see any network at all (Not connected - No connections are available). The networks are visible on other devices.

This is a Laptop from 3 months ago, Asus, no Ethernet port. It came with preinstalled windows 10. I don't know what to do since I'm more an ubuntu guy, so please let me know if you need more info.

The "Network & Internet settings" screen says "Not connected" "You are not connected to any network".

In the screen "Change adapter options" there is only one icon "Ethernet 2, Network cable unplugged".

Troubleshooting asks me to connect an Ethernet cable, which I can't, so is useless.

The "View your network properties" screen has the Wifi properties, with status "Not Present" and Connectivity "Disconnected".

In the "Device Manager" screen, there is an exclamation point inside a yellow triangle in the Network adapter "Intel Dual Band Wireless-AC 8265". Clearly this is where the problem is, but I don't know how to solve it. Device status is "Windows is still setting up the class configuration for this device. (Code 56)"

Any help?

  • Is there a switch, or any key combo, that can turn off the radios in your machine? – dmb Oct 10 '18 at 13:32
  • Have you tried complete reboot (see thewindowsclub.com/…) or SAFE mode restart? – DrMoishe Pippik Oct 10 '18 at 14:09
2

This is probably a driver problem, of course, harrymc has provided the solution for the driver.

However, I still recommend that you check the "WLAN AutoConfig" service in the system service. Find this service, open it or restart it.

2

Try to see if this works:

Go to cmd and run it as administrator and type:

netsh winsock reset

After that just restart your laptop and see if it works. I have only used this when my wireless network card doesn't connect to the internet so it might help and it might not.

1

It is possible that Windows Update has installed a new driver while you were browsing. Some driver updates do not cause a request to reboot.

To test the idea, enter Device Manager, right-click on the device, choose Properties, go to the Driver tab and see if the button "Roll Back Driver" is disabled. It not disabled, click it, and afterward verify that the WiFi works well.

You could also download and install the latest driver from the Intel page of Downloads for Intel® Dual Band Wireless-AC 8265. The driver there is pretty recent and dating from a month ago. I would counsel this even if the above rollback worked after all, since you can always rollback again.

Let me know how it goes.

0

Oddly enough, when waiting for answers, I uninstalled a VPN client (Checkpoint), and it started working immediately. So, no clear diagnosis, but problem solved. Thanks to all anyway.

0

Here's how I fix it without having to restart.

Most of the times the issue is that the wireless adapter encounters some error and Windows turns the device off.

Navigate to the Device Manager (Win + X, M). Under "Network Adapters" you'll most probably see that your wireless adapter has a warning icon (Yellow triangle with exclamation mark). If you hover over the adapter name you'll see a tooltip saying "Windows encountered some issue with this device and has stopped it" or something else to that effect.

Right click the wireless network adapter and select Disable device. Once the device is disabled completely and Device Manager has refreshed the list, right click it again and click Enable device.

That's it, your wifi networks should again start showing up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.