We have a WDS bridge setup for our network, the root router (#1) is a TP-Link TD-W9980 (Dual-band N with built-in VDSL2 modem) and the extending router (#2) is a TP-Link Archer C7 (WDS is enabled for 5GHz) which has a different SSID. This setup has been working very well for most devices.

Recently we picked up a new USB wireless network adapter (TP-Link Archer T2UH) for one of the PCs because the existing one was acting up (TP-Link WN8200ND). This PC runs Windows 7 and connects to the network of router #1 (better signal strength).

However, upon installing the new one, when connected to router #1 that PC can no longer access or ping any devices connected to router #2. Switching back to the old adapter makes it work again, and testing the new one on my laptop showed the same results.

For example, a PC with a wired connection to router #1 has the IP 192.168.1.101 and is accessible, but my PC has a wired connection to router #2 with IP 192.168.1.103 and is not accessible.

Is the adapter DoA, is it a bad product (due to its use of the notorious MT7610U chipset) or am I missing something?

  • 1
    IIRC it is set to Home. File and printer sharing is turned on – OronDF343 Oct 11 at 19:42
  • Do you get the same results with 40mhz channels and up with the TP-Link Archer T2UH? Is it limited to one band or both? – Tim_Stewart Oct 11 at 19:49
  • Our network is broadcast on only 20MHz bandwidth. The T2UH is only capable of 20MHz anyway – OronDF343 Oct 11 at 23:42
  • The manufacturers website seems to contradict your last comment. tp-link.com/us/products/details/cat-5520_Archer-T2UH.html (under the hardware section) seems to indicate it can do "High throughput" 40mhz wide channels on 802.11n (HT40) & "very high throughput" on the 5.8ghz band with 80mhz wide channels. (VHT80). Although I doubt it's relevant to the question it's worth a shot. It sounds like this adapter may be defective honestly. – Tim_Stewart Oct 11 at 23:52

It may be that the IP address of a device connected to the root router (#1) conflicts with the extending router (#2) IP address. It is recommended to reconfigure the WDS bridge router.

How to configure WDS bridge router we can refer to the following article:

How to Configure WDS Bridging on TP-Link Dual Band Routers (green UI)?

  • I'm not sure how you came to that conclusion. If the routers were mis- configured this would be happening on all devices connecting... – Tim_Stewart Oct 11 at 12:57
  • Whether other devices connected to the root router can access other devices connected via WDS bridge router? – Daisy Zhou Oct 11 at 13:18
  • The op states "Switching back to the old adapter makes it work again". Which would Indicate that this problem is isolated to the (TP-Link Archer T2UH) adapter, and not a router configuration issue. – Tim_Stewart Oct 11 at 13:21
  • 1
    Not relevant: The extending router has an IP of 192.168.1.2 which is outside the DHCP range of 192.168.1.100-199. Also, the extending router has DHCP turned off as per the WDS setup requirements. – OronDF343 Oct 11 at 19:41

TL;DR: Not sure what's going on here but it's fixed

There was another PC that had a T2UH but of an older hardware revision (V1.0). This PC runs Windows 10, and did not have the issue! I tried the new one (V2.0) and it worked as well.

I then took the older one (V1.0) and tried it with the original PC and it worked fine! So I have no idea what was going on, but at least it's fixed...

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.