0

I'm running Mint 18.3 Mate on an Intel i5-8600K desktop. I do not have a sound card or speakers. I have a Sennheiser headset that works fine when I listen to something off the web like youtube.

I have a USB piano keyboard and sometimes it works, sometimes it doesn't. I'm using QjackCtl and Qsynth.

When I push a key on the piano, the green light in the lower left corner of Qsynth lights in unison.

In Qsynth, if I open Channels and push a key on the piano, the green light next to Yamaha Grand Piano lights. I do have two soundfont files loaded.

It has worked fine. Then it stops working. I have been searching a lot; what I've found says it should work, as far as I can tell.

Jack audio connections

Jack alsa connections

Qsynth settings

aplay -l

  • "Then it stops working." When? What changed? – CL. Oct 11 '18 at 8:54
  • I'd have a clue if I could answer. Nothing I know of. Clearly something is different. – Steve Oct 11 '18 at 12:07
  • Do other sounds still work? – CL. Oct 11 '18 at 13:23
  • Yes. I have in the past had trouble with Mint losing track of my headset. When the piano doesn't work (all the time now), I check Youtube or something and the headset always works. – Steve Oct 11 '18 at 23:39
0

Possibly I experienced the same issue as you. I now have it working again. It seems, once it starts working with certain settings, it seems to keep working from then on. Unfortunately I don't have a full answer on why that might be.

I'm on Ubuntu 18.04 and Fluidsynth 1.1.9. The technique I used was to go into Fluidsynth (i.e. the command-line tool), play with the settings til it works, and then go back into QSynth and set the same setting values.

What worked for me was:

audio.driver=alsa
audio.alsa.device=pulse   [I have never got any output by going directly to alsa devices. I'm not sure why that is. I haven't tried jack, so you may need to experiment.]
synth.gain=10.0    [The default of 0.2 is inaudible on my system]
audio.output-channels=1
audio.sample-rate=22050.0
audio.sample-format=16bits

Once it was working in QSynth with these settings, I was able to return some of them back to their default values.

  • This works great. It was either setting audio driver to alsa or audio alsa device to pulse, or both. Now I don't need jack. Thanks very much. I must go make notes (both ways).. – Steve Oct 16 '18 at 3:10
  • OK, slight change. I do need to start jack for the piano to connect to Qsynth. Huge improvement over no sound. – Steve Oct 16 '18 at 3:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.