Yesterday shutted down my main desktop pc and after starting it, I noticed the Windows 7 x64 SP1 took unusually long time to load from 'Welcome' screen to desktop. Yes, I was a witness of a ~30min loading glory

Type of BSOL - black screen with mouse pointer and everything working, but no desktop on the satellite images

Machine specs are good enough (I think) - 8c/16t Xeon, 16GB RAM, 2xSSDs for OS, 2xHDDs for storage

Tried everything - disabled all non-MS services, added new admin/normal accounts, stopped all systray apps manually, rechecked SSD/HHD cables, no SSD/HDD errors, reswapped memory/memtested it, removed all currently installed drivers ... It just continues to load after ~30min. After loading it's ok, and it's even ok DURING the limbo - can start whatever game/app I choose through Task Manager>New Task(Run)

Any ideas to fix it or to let it go and upgrade to 8.1/10 ?

Edit: There's something strange in this situation - after loading my 'Quick Launch' all icons on it just warped into the eternity

  • Run CHKDSK; try "Repair" option on your Windows install disk? Maybe boot in safe mode? My money would be on corrupted system files on your SSD. Just as a side note FWIW, I have read many times you "shouldn't" use an SSD for system files because they write data far more often than regular data storage. Sure it's faster, but... – user3169 Oct 12 at 5:43
  • "no SSD/HDD errors". Also almost all non-system writing is stopped or moved to the HDDs – 1000Gbps Oct 12 at 6:22
  • Including sfc /scannow - report is "Windows Resource Protection did not find any integrity violations." and usually the machine was setup to run it each 4 hours when there's no active jobs – 1000Gbps Oct 12 at 6:39

Because I last read my MCSE in about 2001 & therefore have incomplete knowledge of exactly how to go about this type of thing in any truly methodical way like a fully-certified tech would, I would add some of the following fumbling to what you already did...

  • Check, double check & triple check that all your SATA cables are good.
    Earlier this year I lost an entire machine and all recent backups because of an intermittent SATA cable.
    I eventually, after very slowly arriving at that conclusion, had to go back to a backup from over 6 months ago.

  • Try a restore to the last or last but one restore point[s].

  • Run Windows Repair from Tweaking.com (freeware version is sufficient.)[1]
    Expect this to take about half a day to do everything thoroughly; run the actual fixes twice - apparently it can make a difference.

  • If still no joy, I'd just re-image from the last full backup.
    Word of warning - make sure you clone a good, verified backup off to another device every month or so, in case you get what happened to me earlier this year...

[1] No affiliation, just a satisfied customer. It has saved my a** sufficient times that I bought the full version just to reward the author.

  • No real backups of the OS here - its double RAID 1 configuration. Same with restore points - there's a chance to break some projects when restoring system files. The saddest thing is that cables are ok (my first thought too) - no SMART datachannel errors or higher resistance (contacts were also cleaned before installing the drives) Hmmm, updated question with some strange thing – 1000Gbps Oct 11 at 13:10
  • Is it possible the main culprit is the RAID controler? Just managed to see the log and there's a record showing the second drive disconnected and reconnected for about 20 seconds ... – 1000Gbps Oct 11 at 15:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.