0

Trying to install openssl-devel for keepalived-1.4.5 on RHEL7.4.

after sudo yum install openssl-devel I'm getting

...<Processing Dependencies>
Finished Dependency Resolution
Error: Package krb5-workstation-1.15.1-8.el7.x86_64 (@anaconda/7.4)
Requires: libkadm5(x86-64) = 1.15.1-8.el7
Removing: libkadm5-1.15.1-8.el7.x86_64 (@anaconda/7.4)
    libkadm5(x86-64) = 1.15.1-8.el7
Updated by: libkadm5-1.15.1-19.el7.x86_64
    libkadm(x86-64) = 1.15.1-19.el7
.....<More Dependency Errors>

Other dependency errors show available packages in the repos accessible to me. Wondering how to remedy this considering I can't get access to updated repos due to satellite servers though I can get rpm's from a vendor. Most dependencies were already resolved by creating a local repo for yum using the packages the vendor could find with their up to date repo.

Do I need to be updating krb5-workstation? If this is done would it effect kerberos configuration?

Struggling to make sense of the error message so an explanation of how to continue troubleshooting would be phenomenal.

0

libkadm5 and krb5-workstation are subpackages of krb5 package. And both need to be at the same version-release.

You have in repo newer libkadm5 (1.15.1-19.el7) but not krb5-workstation of the same version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.