0

When I am trying to use latex in inkscape (I am using Ubuntu 18.04 and inkscape version 0.92), I am getting the following output:

Inkscape has received additional data from the script executed. The script did not return an error, but this may indicate the results will not be as expected.

And the following is displayed in a white box:

  ./base/gsicc_manage.c:1244: gsicc_open_search(): Could not find default_gray.icc 

| ./base/gsicc_manage.c:2261: gsicc_init_iccmanager(): cannot find default icc profile

  ./base/gsicc_manage.c:1244: gsicc_open_search(): Could not find default_gray.icc 

| ./base/gsicc_manage.c:2025: gsicc_set_device_profile(): cannot find device profile

**** Unable to open the initial device, quitting.

PostScript/PDF Interpreter finished. Return status 256 executed command : /usr/bin/gs -q -dDELAYBIND -dWRITESYSTEMDICT -dNODISPLAY -dNOEPS "/tmp/psinf3HoKG"

The interpreter seems to have failed, cannot proceed !

Traceback (most recent call last):
  File "eqtexsvg.py", line 160, in <module>
    e.affect()
  File "/usr/share/inkscape/extensions/inkex.py", line 283, in affect
    self.effect()
  File "eqtexsvg.py", line 154, in effect
    svg_open(self, svg_file)
  File "eqtexsvg.py", line 81, in svg_open
    doc = inkex.etree.parse(filename)
  File "src/lxml/etree.pyx", line 3426, in lxml.etree.parse
  File "src/lxml/parser.pxi", line 1839, in lxml.etree._parseDocument
  File "src/lxml/parser.pxi", line 1865, in lxml.etree._parseDocumentFromURL
  File "src/lxml/parser.pxi", line 1769, in lxml.etree._parseDocFromFile
  File "src/lxml/parser.pxi", line 1162, in lxml.etree._BaseParser._parseDocFromFile
  File "src/lxml/parser.pxi", line 600, in lxml.etree._ParserContext._handleParseResultDoc
  File "src/lxml/parser.pxi", line 710, in lxml.etree._handleParseResult
  File "src/lxml/parser.pxi", line 639, in lxml.etree._raiseParseError
  File "/tmp/inkscape-QFgxMh/eq.svg", line 1
lxml.etree.XMLSyntaxError: Document is empty, line 1, column 1

It is not generating any latex output. Any solution?

0

Apparently, it was about a broken ghostscript problem and here is how it worked for me

sudo rmdir /usr/share/ghostscript/9.25/iccprofiles sudo apt-get install --reinstall libgs9-common

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.