0

On a Windows XP desktop, I have connected a Zip 250 drive (Z250ATAPI) to the motherboard's integrated J-Micron eSATA/PATA controller. The IDE cable has 2 connectors but only one is used.

It seems the device isn't recognized by the BIOS, as I cannot select it in the boot order menu. If I plug a CD drive in the same connector instead, it works normally. Windows does not see anything either, but if I connect both CD drive and Zip drive together, the CD drive is functional, and I get 50% of CPU usage due to interrupts. The controller is set to IDE mode. I have tried every jumper position and always got the same result.

I have browsed everything in the BIOS' menu, but nothing seemed relevant to this situation. What could be the issue ?

  • You said you tried every jumper position, perhaps no jumper? Better yet, google for the drives master/slave settings. Also, its possible the drive doesnt work. Have you tried in another computer? – Keltari Oct 12 '18 at 12:38
  • 1
    Zip drives are pretty old and uncommon. I wonder if the controller has no idea, or if you need some kinda driver for it. – Journeyman Geek Oct 12 '18 at 12:38
  • I tried without jumper as well. And unfortunately I don't have another machine to test on. Also, shouldn't the BIOS recognize something ? Even if it doesn't know exactly what it is ? – Angry Cub Oct 12 '18 at 12:45
  • What do your autoexec.bat and config.sys look like? – spikey_richie Oct 12 '18 at 12:46
  • Sorry I don't get where those files should be ? – Angry Cub Oct 12 '18 at 13:06
1
+50

This is a left-footed answer requested by the poster:

In a comment on the post, among my suggestions was one that said that some Zip drives are not detectable without a disc inside.

That led the poster to put a disc inside the Zip. It changed nothing, so he pushed the eject button - and nothing happened.

Conclusion: Electrical supply problem interior to the drive.

Problem found thanks to my advice? Well ... sort of.

1

IDE troubleshooting steps:

  1. Is there a key and keyhole on the connector and slot? (If either the key or keyhole are missing it is possible that the ribbon is upsidesown)
  2. Master\Slave - No jumper is slave and default. Jumper can be added for master.
  3. Connect to the furthest of the two IDE connectors for slave. Near one for master.
  4. Check the power connector. You should get a green light with the machine powered on and a disk in the drive.
  5. Check BIOS. If the drive is not detected in BIOS, turn off auto detection. You may need a BIOS update if your MB is not compatible.
  6. Install the correct drivers for your OS\Hardware combo. (XP doesn't come with Zip drive drivers)
  7. This device is not compatible with 64-bit windows.

HERE IS THE MANUAL FOR YOUR DEVICE: https://usermanual.wiki/Iomega/Iomega3798300UsersManual353470.743001910.pdf

Follow the installation guide in the manual.

  • Clarification: With early versions of the specification it wasn't stated which connector should be for "device 0" (a.k.a. Master) or "device 1" (a.k.a. Slave) and some manufacturers implemented the "Cable Select" function by cutting the relevant wire in the cable between the two device connectors, however this caused some issues and in later versions of the standard they did specify that "device 0" (Master) should be on the furthest connection from the motherboard & "device 1" (Slave) goes on the one closer to the motherboard. Like so: Image – 3D1T0R Oct 19 '18 at 18:56
  • Useful for general purpose, but in my case the solution was actually already found in the comments. – Angry Cub Oct 20 '18 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.