0

I'm trying to run a MediaWiki script called RunJobs.php, which I have done many times before on the same system. All of sudden, today when I try to run the script in CMD on Windows 10 instead of running, it launches Notepad++.

I've tried to solve this by adjusting file associations, to no avail. I tried to remove file associations altogether through right-click, control panel, and through Notepad++ preferences. None of that worked.

I even tried associating .php files to C:\wamp64\bin\php\php7.0.10\php.exe.

My Question

How can I get my .php files to run in Windows command prompt again like they used to?

P.S.: I know how to troubleshoot and I can't identify anything that I changed that may have caused this problem.

Resources

This post was close, but unfortunately, not a duplicate and didn't offer the answer to my challenge:

0

It sounds like the key HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\php.exe has a Debugger string with the value C:\Program Files (x86)\Notepad++\notepad++.exe like Notepad2 does.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.