I have an Intel Core i5-6400 CPU installed on a ASUS Z-170A mainboard. According to the documentation of my CPU, this CPU supports Intel Virtualization Technology (VT-X) and it is listed as compatible with HAXM for Android. I have Windows 10 Pro (64-bit build 1803) and VT-x is enabled in BIOS settings, and Memory Integrity is disabled in Windows Defender. I could not run virtual machines in VMWARE since it prompts for error:

VMware Workstation and Device/Credential Guard are not compatible. VMware Workstation can be run after disabling Device/Credential Guard.

However, when I use Intel(R) Processor Identification Utility, it reports that my CPU does not support VT-X. This prevents installing HAXM for Android. How do I resolve this?

Screenshot from Intel(R) Processor Identification Utility

  • What security software do you have installed? Edit your question to include this vital required information. I assume you have already installed Hyper-V, which by default, is required for the Android emulator you plan on using.
    – Ramhound
    Oct 12, 2018 at 15:16
  • 2
    Have you enabled VT-x in the BIOS? Asus defaults is "disabled". Oct 12, 2018 at 15:21
  • 2
    Other folks with this issue have found resolution by going into BIOS Setup, disabling VT-x, saving the Setup change, turning the PC off, rebooting, going back into BIOS Setup, and turning it back on and saving the change again. Please try that and report the result by clicking on edit above at left, and adding that into your original post.
    – K7AAY
    Oct 12, 2018 at 16:39
  • @K7AAY I should thank for your follow up. finally this problem resolved
    – VSB
    Oct 17, 2018 at 18:55

1 Answer 1


Unfortunately VMWare prompt and its resolution document was misleading and not explanatory enough to help me.

To enable VT-x besides of enabling it in BIOS, uses should Disable Windows Defender Credential Guard as below:

  1. Run gpedit.msc and then go to:

Computer Configuration -> Administrative Templates -> System -> Device Guard -> Turn on Virtualization Based Security

and select Disabled option.

  1. Then run regedit and delete these keys if they are present in registery:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA\LsaCfgFlags HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceGuard\EnableVirtualizationBasedSecurity HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceGuard\RequirePlatformSecurityFeatures

  1. Execute cmd as administrator and run below command to enable NX bit:

bcdedit.exe /set {current} nx AlwaysOn

  1. For me, the magic part was this. run regedit and in folder:


set Enabled to 0.

Here is the result: enter image description here

P.S. Great thanks to Ulises2k for his/her answer at https://social.technet.microsoft.com/Forums/windows/en-US/8004c3bd-7d57-40ce-93de-0b1a6babd64c/how-i-can-disable-credential-guard?forum=win10itprovirt which helped me for part 4 of this answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.