This issue seems to be pretty common on the web, but I can't seem to get anything to work. Basically, I've created a persistent Arch USB that's set up for mining. It boots and runs fine on my PC and in a VM on my laptop. My PC also has a Gigabyte mb and the drive shows up as GRUB (SanDisk). On the rig however, it shows up as "UEFI: SanDisk, Partition 1" and if I enable Legacy USB I get another entry that just says SanDisk.

Booting from the UEFI just brings me back to my BIOS setup while booting from the SanDisk entry tells me to reboot. I just updated my BIOS and the same behavior is happening. I should be booting with UEFI the same as I was on the other motherboard but for reason this is messing up. Enabling and disabling Mining Mode doesn't seem to do anything.

Thanks for any help you can give.


A disk may have several UEFI bootloaders coexisting in the same EFI system partition. Their filenames and labels are stored in NVRAM, and if there aren't any, then a single default path is used.

For portable drives, since you can't carry the NVRAM contents with you, relying the default path is the only useful method. But grub-install doesn't care, it uses a custom path no matter where you install it.

On your old system, look at the output of efibootmgr -v. It will show that an entry labelled "GRUB" most likely uses \EFI\arch\grubx64.efi or something like that. (The paths are DOS-style, case-insensitive, and rooted at the EFI system partition – so this probably corresponds to something like /boot/EFI/arch/grubx64.efi in Linux).

Copy that file to the default path, \EFI\Boot\BootX64.efi for a 64-bit system (i.e. /boot/EFI/boot/bootx64.efi or something like that).

  • Well first this worked and I want to really thank you bc this is the second question I've had and you've answered both of mine really quick. Second, I was wondering if because it's looking for the default path to the boot loader, why did it boot correctly on my PC and laptop? – user2455722 Oct 12 '18 at 19:14
  • Perhaps both had NVRAM entries from doing grub-install. – grawity Oct 12 '18 at 19:15
  • Oh so if I run grub-install on the computer, it retains the path to the GRUB directory, but since I had not on the rig, it was looking in the default directory and found nothing. Did I interpret that correctly? – user2455722 Oct 12 '18 at 19:16
  • Yes. Although the NVRAM entries contain both the path and the disk UUID. So each entry knows to look for grubx64's path on a specific disk only, and I'd expect it to work only if you had run grub-install targeting your portable disk specifically. (Check the same efibootmgr -v output to see it.) – grawity Oct 12 '18 at 19:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.