0

I use Audacity's WASAPI feature to do all loopback recording. Recently I've had a problem where it will not start recording until it detects any sound, instead of recording right away regardless of whether sound is currently present or not.

I can see how this could be useful, but this "feature" is entirely useless. Audacity ends up clipping the first instant of the recording. So instead I must record an instant of some audio clip, perhaps the thing I'm trying to record, then rewind the audio clip (if I'm able to do that), and then stop the recording, delete everything recorded so far, click "Record" again, and then start the audio playing again.

I'd prefer to avoid all that if I could. It was very easy before and now they've made it so difficult.

The strange thing is when I first installed Audacity, it worked normally for a couple recordings. But soon after it started getting buggy like this again. Every once in a blue moon, it will work randomly but 15 out or 16 times it does not.

So, how can I change Audacity's behavior back to normal?

Sound Activated Recording is turned OFF in preferences.

0

I don't know how to fix the bug, but I know a workaround:

  1. click Record
  2. click Stop
  3. click Record

then the recording should start.

enter image description here

  • 1
    This used to work for me but no longer does. The only workaround is play some random audio to trigger it to start recording, stop Audacity (and the audio), delete what was recorded, and hit Record again and it will start – InterLinked Jan 10 at 2:02
  • Ah that's annoying. You can also try to download the previous releases of audacity, and see if one of them work fine. Dunno if you can have different version of the same program at same time though. – sound wave Jan 11 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.