0

I'm having this quite peculiar problem while trying to install this printer through USB.

Recently, I formatted my system and reinstalled Windows 7 Pro (x64) and I can not reinstall this printer anymore. It was fine before the format of the pc.

I tried installing driver from CD that came along with the printer but all in vain.

I also downloaded driver from this official website and install it's the same. These are the screenshot below after I run application & install the printer driver. enter image description here enter image description here

And if I try to forcefully install driver from device manager then it's the only result that I get.

enter image description here enter image description here

Apparantly, the printer is not getting installed in the correct port no matter how much I try.

Any suggestions?

0

Try the following way:

  1. Uninstall the installed printer driver.

  2. Restart the computer.

  3. Download the following printer driver according to the official website you provided and decompress print driver:

enter image description here

  1. Right-click e-Studio242 in this screenshot.enter image description here

  2. Select update driver, select the printer driver we just downloaded and saved in the directory.

  3. When we installed, we check if the e-Studio242 is in printer support->Universal Serial Bus Controllers, if so, it should be OK.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.