0

I have a freshly set up HP Microserver with Debian Stretch. I set up a RAID5 with LVM on top and built an lvmcache. home is a symlink pointing to a directory on that LVM. Its mounted via /etc/fstab (after /, of course). Set up the lvmcache like here.I already set this up twice. No effort.

I can boot when removing the lvmcache from data partition. When I enable the cache on a running system, the cache is used and works. So, it's a boot problem.

When the error appears, lvscan shows the data partition is inactive. It says waiting to connect to lvmetad and it's waiting 1:30mins for a strange device name (somethiong like /dev/mapper/x2d...). I dont have this device name on my machine.

Workaround (disabling the cache during boot):

lvconvert --splitcache server-vg/data
lvchange -ay server-vg/data
lvscan                            # check if its active again. 

This is the only one thing I changed and then its booting again. But I'd really like to use this cache.

  # lvs -a
  LV                 VG        Attr       LSize  Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  cache-data         server-vg Cwi---C--- 20,00g                                                    
  [cache-data_cdata] server-vg Cwi------- 20,00g                                                    
  [cache-data_cmeta] server-vg ewi------- 24,00m                                                    
  data               server-vg -wi-ao----  1,82t                                                    
  [lvol0_pmspare]    server-vg ewi------- 24,00m                                                    
  root               server-vg -wi-ao---- 27,94g                                                    
  swap_1             server-vg -wi-ao----  3,96g

Here, you can see the cache policy mq is set. At beginning this was set to smq, The change did not help. from here

# lvs -o+cache_policy,cache_settings server-vg/cache-data
  LV         VG        Attr       LSize  Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert CachePolicy CacheSettings
  cache-data server-vg Cwi---C--- 20,00g                                                     mq  

Please let me know if you need further info. Don't want to post tons of output here while I don't know if its helpful.

I already googled a lot but did not find any solutions for this problem related to lvmcache. But I also did not find any posts saying that Debian is not able to use lvmcache...

This cache_check solution for a similar problem also didn't fix anything for me.

1

I met the problem same with you.

I have 3 lvs(collection, study, anonymous) in a vg(nasvg) and use a ssd for study-lv with lvmcache. Nothing wrong happened when I installing it, but when I reboot, I got the same output with you. After I commented the mount of study-lv in /etc/fstab, it boots successfully. Also, lvscanshows the study-lv inactive, and once I try to active it, I got that /usr/sbin/cache_check execvp failed no such file or directory

I got help from here https://bugs.launchpad.net/devstack/+bug/1615134. Seem that the lack of package "thin-provisioning-tools" make my lvmcache down.

Then, with sudo apt-get install thin-provisioning-tools, and sudo vgchange -a y nasvg, everything was ok and I can boot successfully now with lvmcache.

Here is my evironment:

ubuntu 18.04(amd64)

LVM version: 2.02.176(2) (2017-11-03)

  • You are my hero!! Another pproblem with my server was the USB backup disk which was mounted in /etc/fstab automatically. Added the options noauto,user,defaults here. That caused the timeout error. – Corni Oct 17 '18 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.