0

I've got the usual browsers with Gecko and Blink engines. Never had a problem with the original simple version of CAPTCHA.

https://pasteboard.co/HIFYAg8.gif

If I try over and over, one of my browsers might render "I'm not a robot" followed by the thumbnail array of selectable images. There are hundreds of possible fixes. Just type "browsers not rendering reCAPTCHA" into any search engine. I've tried more fixes than I can remember. Nothing seems to work.

There are a few sites that I've used for years. I can't login anymore because they recently adopted reCAPTCHA.

This may be a drastic solution, but I'm looking at tiny Linux distros that can boot from within a host operating system, like Damn Small Linux (DSL). I'm guessing the browsers included with these small distros will render reCAPTCHA normally.

http://www.damnsmalllinux.org/

Since nothing I've tried has fixed the reCAPTCHA problem, should I download a distro that can launch inside Windows?

  • So this only occurs within your Windows operating system, linux is unaffected and "just works"? – Mokubai Oct 16 '18 at 7:15
  • Which browsers have you tried, and are you on Windows? Have you tried with your anti-virus disabled? – harrymc Oct 16 '18 at 7:17
  • What antivirus or antimalware do you have installed? Do you use any browser "cleaners" or malware services such as Malwarebytes or Spybot Search and Destroy? Is your hosts file clean? What version of the operating system are you using? What browser versions? – Mokubai Oct 16 '18 at 7:19
  • Seeming as though many hundreds of thousands, even millions, of users who use such services that Google provide - such as their CAPTCHA - without problem then one might assume the problem is on your computer. As @Mokubai has stated, do you have any malware on your computer that may be hijacking your browser(s)? Do you have any browser add-ons that may be performing something you've wanted, with a side-effect (CAPTCHA not working) that you're unaware of? Have you tried another computer? – Kinnectus Oct 17 '18 at 10:00
-2

On OS Windows XP, browser Firefox 47.0.2. I've added the "User Agent Switcher" addon from: https://addons.mozilla.org/es/firefox/addon/user-agent-switcher/ downloaded the addon last list from: https://techpatterns.com/downloads/firefox/useragentswitcher.xml and imported it from the addon's Options. I deleted all cookies that refers to google and capt. I changued on Default User Agent following this path: Tools - Default User Agent - Mobile Devices - Browsers and I selected "Firefox 48.0 - Android 6.0.1 (Samsung SM-G935F)". And recaptcha started working. This is not a problem with OS, browsers or protocols. The problem is whith Google, that restricts the access to some browsers and OS.

  • 2
    Hi. You've made a sweeping statement there. Please provide some documentation on "The problem is whith Google, that restricts the access to some browsers and OS." – Stese Oct 17 '18 at 9:42
  • The test was done on the same PC, and the only changes were the steps described. This means that under the same conditions, and only by changing the information that is sent to the site, in this case Google, I accessed to a page, the which was otherwise rejected asking for an update of the browser to a version that would means an OS update. – HGRF Oct 17 '18 at 21:58
  • That does not prove that google is restricting access. All it shows is the problem is limited to that machine. There could be firewall or other similar networking elements that are causing this. – Stese Oct 18 '18 at 9:40
  • If it were a firewall it would have to be on the server with which I want to connect, in this case Google. But it should block my IP, not according to browser type, or OS that I am using. The tests were made with the same PC and IP. – HGRF Oct 19 '18 at 22:57
  • no, the firewall could be on the computer with the fault. Given you've not shown this is a problem others are reporting, its highly likely the issue is on faulty pc. – Stese Oct 21 '18 at 5:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.