1

I have a work computer, and I occasionally work remotely. Computer is fast enough - latest i5 processor; 512 ssd; 8 gb mem. Should be fine, and is fine in almost all contexts.

What happens happens ONLY when the following is true:

  1. I am working at home
  2. I am using my work computer
  3. I go to search for something in the URL bar (which is configured to search google)

When all those things are true, there is a noticeable delay. It's like I type it in, and literally nothing happens for maybe 2 seconds (which seems like an eternity when it's unexpected), and then, after those 2 seconds, it goes through the motions of loading google.com. Which takes as long as I expect it to take - like a 10th of a second or something.

It seems like the delay comes prior to loading. How it looks to me - granted this is speculation - is that the delay is taking place before the loading. It's like the delay is caused by the value being parsed from the url bar.

I've tried the following to fix it.

  1. Disabled addons (these are the same ones I use on other computers anyway)
  2. Cleared cache/cookies/et. al
  3. Tried other browsers -

    a. Chrome - delay

    b. Chrome Canary - delay

    c. Internet Explorer - no delay (that's interesting)

  4. Messed with all the settings that seemed relevant both on chrome://settings and chrome://flags

    (edit: Unfortunately I don't remember what settings I tried to adjust - hardware acceleration both ways; url search settings; etc - I did it scientifically though - I'd make the change - try it - and then if the results were the same, I'd set it back. I wanted to see if I could isolate a setting that was causing it, and I couldn't)

  5. Tried different DNS servers - Cloudflare

  6. Turned off IPV6

I'm kind of at my wits end here. The fact that it doesn't happen with IE is really odd. The delay is annoying to the point where I'm thinking I'll keep an IE window open just for Google searches - but that seems dumb. Maybe I'll install FF, but I really prefer Chrome.

I have some enterprise Symatec antivirus installed. If that's causing the problem, I'll have to consult our IT department, and can do nothing with it since all the settings are locked. I can't kill it either. I can't think of the best way to debug that.

I did an Internet speedtest, and got 21.7 MBPS download and 1.53 upload, which is plenty fast enough I'd think. I'm also running gigabit ethernet. Windows 10.

If this is a known bug, I'd love to know it; or if anyone has any suggestions for debugging, I'd appreciate it. It's really irritating me. Thanks.

3
  • What happens when you ping google.com from your work computer @ home versus your home computer @ home? Oct 16, 2018 at 15:20
  • @K7AAY - I forgot to include I did try and set dns servers.
    – dgo
    Oct 16, 2018 at 18:19
  • Please change your DNS servers to 8.8.4.4 and 8.8.8.8 then ping them, and paste the results of the ping into your original question.
    – K7AAY
    Oct 16, 2018 at 20:24

1 Answer 1

2

This sounds like a dns issue to me. Since it's a work computer they may have installed a VPN or enabled Direct Connect which means your DNS query's must first query a server designated by the IT department where you work. If this is the case you can see it in network and sharing center > change adapter settings or from the cmd prompt. Just type "ipconfig /all" and you may see virtual adapters listed. Troubleshooting issues without administrator rights on the PC makes things more difficult so it may be worth it to contact your work's IT department.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .