0

Ok, macOS / Linux native here on Windows territory and a bit lost.

I'm helping a family friend upgrade to Windows 10. He has a company laptop that he was allowed to keep after his retirement. It had Windows 7 Pro on it. I upgraded it via Microsofts own Upgrade application and it worked great. All files/folders still in place and all applications working smoothly, except for the Windows (Defender) Firewall:

  • When I look at the firewall setting in the renewed settings menu it is set to "off" and the button is greyed out.
  • In the configuration screen -> firewall settings there is an exclamation mark with a warning message that the firewall isn't set to it's default settings. There is also a button to restore the default setting but pressing it throws an errorcode 0x80070437

enter image description here

  • Within the Windows 10 settings app there is also a firewall status screen that shows:

enter image description here

  • I tried logging into the administrator account to press the same button but same error persists.
  • I downloaded & ran the "Windows Firewall Troubleshooter" program but it also failed to solve the problems. In the detailed report it read:

"Windows could not start the Windows Firewall on Local Computer"

  • I tried running services.msc and starting the Windows Defender Firewall service from there but it keeps shutting itself down directly after it starts.
  • Finally I tried restting the service via CommandPrompt (run as Administrator) using the command Netsh advfirewall reset but it returns:

enter image description here

EDIT 1

By advice of @harrymc I also tried the solution offered here which boils down to giving the “NT Service\MpsSvc” account adequate permissions, but the errors still persist..


I am left without a clue as to what I can do to further diagnose the problem?

  • Check the procedure in this answer and if the described permission is there, if not add it. If this is still not enough, do it also for registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp. – harrymc Oct 17 '18 at 8:42
  • @harrymc Thnx, will do! Will report back findings. – Montmons Oct 17 '18 at 9:29
  • @harrymc - Unfortunately it did not work, I edited my Question to include this failed attempt as well as adding in some screenshots. – Montmons Oct 21 '18 at 11:07
  • Have a look at this article for resetting Windows Defender settings to the default. – harrymc Oct 21 '18 at 11:11
  • @harrymc - Yes, I saw that article before, I believe I tried all methods. I am sure of the first 3, all failed. I am doubting now about the 4th, the powershell attempt. Will retry that during my next attempt and report back. – Montmons Oct 21 '18 at 11:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.