0

I've connected MS Windows through the explorer (File Manager) with a WebDAV server. Everything seems to work correct, I can download files and create directories. But if I try to upload files to the server through the mounted network drive, I got the message that the file already exists.

I'm definetly sure that the file doesn't exist! However I tried to "overwrite" the allegedly existing file but it also doesn't work! If I tried to overwrite it, Windows cancels the action with the following message:

Die Quelldatei oder vom Quelldatenträger kann nicht gelesen werden.

English: Can't read from source file or disk

Moreover I can edit already existing files and save changes for some file types like *.java files for example. My IDE IntelliJ sends a warning but seems to support updating the file. But I still can't upload files!

Any ideas to solve this issue?

5
  • Is "Require Lock for Writing" set in WebDAV Settings under Lock Behavior? If set, does setting it to False changes anything?
    – harrymc
    Oct 17, 2018 at 17:35
  • @harrymc I'm not sure if I understand you write which WebDAV settings do you mean? I connected with the WebDAV server through the windoss file explorer I didn't find any WebDAV specific settings? Oct 18, 2018 at 5:14
  • It's done on the server side.
    – harrymc
    Oct 18, 2018 at 6:55
  • @harrymc Okay that doesn't solve my issue... The owner of the WebDAV server is the university so I doesn't have any control about it Oct 18, 2018 at 8:49
  • Perhaps you should contact the university's WebDAV administrator and ask him how to do it in an authorized manner.
    – harrymc
    Oct 18, 2018 at 8:51

0

You must log in to answer this question.

Browse other questions tagged .