My current mouse is a several year old Darkfield-type from Logitech, and my current computer is an HP Pavilion x360 laptop running Windows 10.

About a week or 2 ago, I started having issues where the cursor would stop registering movement for about half a second at a time. This seems to happen on a variety of different surfaces, so I don't think that's the problem.

Is the mouse just getting old, or is there something I can do to fix it?

Things I have tried: -updating drivers for mouse, USB port -changing which USB port is used -different surfaces (it feels more like a lag problem anyways)

  • Wireless, I presume? If not, check another USB port; otherwise, change the batteries, relocate the 'dongle' of whatever sort to somewhere else, different port, &/or if on an extension cable different location, right next to the mouse, away from any monitor, fridge, microwave... try a 'solo' USB port, not one shared with anything else, no hub, etc...
    – Tetsujin
    Oct 17, 2018 at 15:32
  • The batteries are fine, it has an indicator light that glows red when they're low. I will try the other suggestions though! EDIT: I tried changing the port, but it didn't help. Thank you anyways.
    – user40146
    Oct 17, 2018 at 15:49
  • Please always specify the model number of anything you ask about. Click on edit above and to the left and add the model number to the original question, as well as the results of anything else you have tried which was not already mentioned in the original post.
    – K7AAY
    Oct 17, 2018 at 15:59

2 Answers 2


Not an unknown issue. Clean the optical sensor/laser port area under the mouse. Disassembly is not required. Use a clean Q-Tip, lightly moistened with water. Should that not resolve the issue, and if Tetsujin's suggestion above is also fruitless, contact Logitech Support.

  • How do I do this?
    – user40146
    Oct 17, 2018 at 15:51
  • I'm afraid this didn't work, thank you though!
    – user40146
    Oct 17, 2018 at 16:29

I don't have the same mouse as you, I have the Logitech G403 Prodigy, however I did experience the same symptoms. I was able to reproduce the issue by simply moving my taskbar from one monitor to the other, this caused the lag. I tried a bunch of tips, until I found a reddit thread where (presumably) a logitech employee replied.

These exact steps solved it for me:

  1. Uninstall the (logitech) gaming software.
  2. Open search box(windows+R) and type %Appdata%.
  3. Delete the Logitech folder in AppData.
  4. Open Device Manager, go to "Mouse and other pointing devices" and uninstall all Logitech devices you see there(right click, uninstall).
  5. Download latest LGS (https://support.logitech.com/en_us/software/lgs) from the web.
  6. Disconnect the mouse from PC and keep it disconnected
  7. Restart PC.
  8. Install latest LGS.
  9. Restart PC.
  10. Plug the mouse into a different USB port.

Source: https://www.reddit.com/r/LogitechG/comments/asoe9b/logitech_g403_wired_stutterdoes_anyone_know_a_fix/eh9pi0j/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .