0

Recently I switched internet providers, and so I was provided a new router (which is locked to the ISP so I cannot use my old router) with a new IP. After setting it up and port forwarding my server ports, everything seemed to work, and canyouseeme.org could see my open port 21. I changed my PC's static IP to match the router's range and I re-configured my IIS FTP server with the new IP. I can access the FTP server from within my LAN, no problem. However, when I try to access it from my public IP, things begin to fail.

The browser requires authentication, as usual, but when I put in my Username and password, the browser loads for a bit, and then prompts me again to enter my credentials. I an 100% sure I am using the right credentials as I can access the server from the LAN with those same ones.

I have tried it with the AndFTP app on my phone and the same thing happens. I do not understand why this would happen when everything seems to be properly set up, especially since I can access my VNC and teamspeak servers without a problem.

I have tried disabling the firewall completely, but no luck.

  • Are you accessing the public IP address from inside or from outside? Are you sure you're connecting to your PC's FTP server, and not to your router's? – grawity Oct 18 '18 at 8:42
  • I don't understand what you mean by "Inside or Outside". I have tried both to use my wifi to connect to my public IP FTP server and my phone's Mobile data. I haven't had any luck. I'll look into the fact that I may be connecting to my router. – techgenius101 Oct 18 '18 at 8:51
  • 1
    FTP needs another port for data transfer. Additionally when a client and a server communicate they include IP addresses and ports inside messages, on a different layer than you would expect. That's why crossing NATs and firewalls may be troublesome. Some routers can deal with these issues better than others, possibly with additional configuration. See this article and consider less ancient protocol. – Kamil Maciorowski Oct 18 '18 at 9:04
  • @KamilMaciorowski What other easy alternatives can you suggest? – techgenius101 Oct 18 '18 at 9:28
  • @grawity I was indeed connecting to my router. Unfortunately, the router I received is one that isn't very popular, so I need to figure out how to disable the inbuilt FTP myself since there aren't any guides online. Go ahead and add your solution as an answer so I can accept it. – techgenius101 Oct 18 '18 at 9:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.