I currently am trying to add a few drives to my server. However, whenever I branch them, they do not appear in /dev. I checked, they are not listed in my BIOS either. Whenever I use gparted or fdisk they do not appear in devices list either, but if I branch them via a USB to sata cable, they do appear.

I formated a disk via said cable and tried to put it back in the server ; it makes an orange light, when I have a green light for the already installed drives, and no light at all for all the other drives - however it is still not detected.

I was thinking about flashing my bios and hoping for a miracle, but as there are important services on the server, I would like to try everything before doing something that could make the server unusable. I guess I could try to branch them via usb but I won't have enough ports, and the problem will remain.

For technical details, the disks are 5To Seagate Barracudas and there are 4 of them. The server is ~6 years old and runs on ubuntu 18.04. The initial drive works flawlessly.

Thank you for your time,

Frost

  • Add some more info about disk type and connectors used, BIOS or UEFI, disk format, computer model. – harrymc Oct 18 at 9:22
  • The specific drives are those When I run sudo efibootmgr, I get EFI variables are not supported on this system. I did not know that there was a limitation of storage space on BIOS, so I guess this is the problem : do you have a solution ? A similar server can be found here : here – Frost Oct 18 at 12:20
  • @harrymc Do you have a clue about the way I should solve this problem ? – Frost Oct 25 at 12:42
  • Are the disks internal? What kind of a case for all these disks? What is the PSU? – harrymc Oct 25 at 12:49
  • Yes, all 4 disks are internal. As for the cases, well, the drives are bare, there are no disk holders in the drive slots so the drives are just just lying in the slots, I'm not sure what you mean. As for the PSU, I have 4 PSUS, 1200W tops each so there should not be any problem. – Frost Oct 25 at 13:25

It sounds like it could be a power issue. Since you proved the disks work ouside your computer, we know they work. If your computer's BIOS doesn't see them, it's likely they aren't spinning up from a lack of power.

Try disconnecting the power from your current drives and connecting the new ones. If they spin up and BIOS sees them, your PSU isn't capable of supplying enough power and needs to be replaced.

  • Well, I don't know, sofar I only had one SSD, so the power consumption should be fairly low. I'll try it anyway when I can afford a bit of downtime, but I would tend to think the problem is elsewhere... – Frost Oct 22 at 14:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.