1

I'm running Windows 10 Home (x64, not activated) in oracle VM Virtualbox on Linux Mint 19. I'm having trouble with a shared folder. On the host it is /media/Lukaka/WP30 and it is shared so on the Virtual Windows 10 as E:\. When I apply the hidden attribute to any files or folders in this location (whether by the attrib command or manualy in properties), it looks like it's worked but it goes back to an un-hidden file. I'm not sure if this is a linux, virtualbox, or Windows problem, but Ideally it would not do this.

2
  • Are hidden files in shared folders allowed on VBox?
    – Xen2050
    Oct 19 '18 at 12:35
  • I'm not sure...
    – Mark Deven
    Oct 19 '18 at 14:12
1

It's a linux share. Go with the flow and rename the file to .something.txt (with the leading '.') This works for me on Debian 9 Vbox 5.1.38 and Win 7.

Files that start with a '.' are hidden in linux and Virtualbox respects this when displaying them in Windows.

Windows attributes can't be mapped directly to linux permissions because they are too dissimilar. If you really need to do this you would need to set up conventional Windows file sharing with Samba on the Linux machine and look into the options Samba gives for mapping windows file attributes.

2
  • What would renaming it achieve?
    – Mark Deven
    Oct 19 '18 at 14:12
  • See the edit to the answer
    – Mbo42
    Oct 19 '18 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.