1

My MacBook won't boot to macOS anymore, only on Linux (Ubuntu). Even restarting with pressing alt doesn't show the macOS disk option anymore.

Here is what happened:

  1. I set up a dual boot High Siera / Ubuntu 16 on my laptop with rEFInd boot manager. Everything worked fine.
  2. I created a new partition from Mac using Disk Utility to be both accessible from Mac and Linux (I chose the exFat format). I got a double message popup before to confirm (see below).
  3. The partition was created successfully, I copied some data from my Mac, and did a reboot on Linux to confirm I can access it. It worked well.
  4. From there I couldn't boot on my Mac anymore, the icon was gone at startup time. I can boot on Linux but not on Mac.

Popup Messages during partition creation:

Partitioning this device will change some of the partitions. No partitions will be erased.
This partition will be added "New partition"
This partition will be resized "Existing partition"
"Cancel" or "Partition"


Boot drive repartitioning:
This partition operation is modifying your boot volume. When the boot volume is resizing the screen may freeze potentially for long periods. Do not power your computer off while resizing is occuring.
"Cancel" or "continue"

Before the reboot, macOS was working fine. But after the reboot, the macOS option was gone.

Any idea how to fix this?

$ fdisk -l

Device         Start       End   Sectors   Size Type
/dev/sda1         40    409639    409600   200M EFI System
/dev/sda2     409640 911627655 911218016 434,5G unknown
/dev/sda4  927225856 934842367   7616512   3,6G Linux swap
/dev/sda5  934842368 977104895  42262528  20,2G Linux filesystem
1

Boot using Command+R -- this will launch Internet Recovery Mode. Release the keys when you see the Apple logo or a spinning wheel.

Internet Recovery Mode will download necessary firmware files to launch Recovery Mode on your Mac, even if it was somehow overwritten in the EFI. From there, you should see a macOS Utilities screen. Select "Reinstall macOS". Follow onscreen prompts. You do need an Internet connection.

If something goes wrong with Internet Recovery Mode (which it shouldn't), you can always try Option+Command+R or Shift+Option+Command+R (increasing severity). The latter will install whatever OS came with your Mac out-of-the-box.

Good luck.

  • Thank you for your insight; it is very much appreciated. I actually just had it fixed, and I will write down the exact steps I did, if ever it can help anyone else. I couldn't restart into internet recovery mode because somehow, my builtin "R" laptop key is dead and not responding. However I created a new installation disk, and I started from there. – Yoric Oct 20 '18 at 7:41
1

Here is how I solved my issue:

  • Reboot from MacOS installation disk
  • Open the terminal utility
  • Enter the few commands below

  1. Look at the format of your partitions. One of mine had FFFFFFFF-FFFF-FFFF-FFFF-FFFFFFFF

    with the command:

    diskutil list
    

    diskutil list

  2. Inspect the corrupt partition in greater details

    with the command:

    gpt -r show /dev/disk0
    

    enter image description here

  3. Repair the partition GUID

    with the commands:

    diskutil umountDisk disk0
    gpt remove -i 2 disk0
    diskutil umountDisk disk0
    gpt add -i 2 -b 409640 -s 911218016 -t 7C3457EF-0000-11AA-AA11-00306543ECAC disk0
    

    At that very moment I had this error (if you don't have this error, you can skip the commands below, and go directly to the verification):

    gpt add: disk0: error: no space available on device

    And I fixed It with the commands:

    gpt -r show /dev/disk0
    diskutil umountDisk disk0
    gpt destroy disk0
    gpt add -i 1 -b 40 -s 409600 -t C12A7328-F81F-11D2-BA4B-00A0C93EC93B disk0
    gpt add -i 2 -b 409640 -s 911218016 -t 7C3457EF-0000-11AA-AA11-00306543ECAC disk0
    diskutil umountDisk disk0
    gpt add -i 4 -b 927225856 -s 7616512 -t 0657FD6D-A4AB-43C4-84E5-0933C84B4F4F disk0
    diskutil umountDisk disk0
    gpt add -i 5 -b 934842368 -s 42262528 -t 0FC63DAF-8483-4772-8E79-3D69D8477DE4 disk0
    

    enter image description here

  4. Final verifications before reboot

    with the commands:

    diskutil list
    diskutil verifyDisk disk0
    diskutil verifyVolume disk0s1
    diskutil verifyVolume disk0s2
    

All went back exactly as before! What a relief! Obviously you need to adjust your commands with your own situation. There are more details about it In this thread

My deepest gratitude to GintsK and klanomath for having been kind enough to document their similar problems and solution. I couldn't have made it without.

0

I've had good luck using the rEFInd utility as described in the OpenSUSE Macbook installation instructions. It might be useful to install that boot manager (it can be installed from Linux) and see if that helps? Either way, there may also be other useful things for you on that wiki page. :)

  • Thanks for your links. Yes, actually rEFInd is the very same boot manager I installed for my dual boot. I'm reading more about it right now to figure out what's wrong. – Yoric Oct 19 '18 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.