I am trying to unzip a file with the size of 2GB
I am getting the following error :

unzip CLTE_C_08.zip
Archive: CLTE_C_08.zip
End-of-central-directory signature not found. Either this file is not a zipfile, or it constitutes one disk of a multi-part archive. In the latter case the central directory and zipfile comment will be found on the last disk(s) of this archive.
unzip: cannot find zipfile directory in one of CLTE_C_08.zip or CLTE_C_08.zip.zip, and cannot find CLTE_C_08.zip.ZIP, period.

After some googling, some people say that this error is because the file is too big, others say because file is corrupt, others say that it could be a not unix archive.

So my question , how to find out if file is valid archive file on my Centos and what is the command/trick to uncompress big files ( if any )

Thanks in advance :)

I issued the command file CLTE_C_08.zip , it gives the following :

file CLTE_C_08.zip

CLTE_C_08.zip: data

I tried viewing the file info on my own computer and i got this :

file avatarminis.zip

avatarminis.zip: Zip archive data, at least v1.0 to extract

Does the above difference mean that CLTE_C_08.zip is not a zip file to start with ?

  • Hello, welcome to Super User. Your question has been migrated here, where it is more adapted. To regain ownership over your question, you should create an account here, and associate it with your Server Fault account in user options.
    – Gnoupi
    May 2, 2010 at 14:00
  • Also, note that these sites are not discussion boards. If you want to add more details, or feedback, do so by editing your question. Don't add an answer, if what you have to say doesn't answer the question.
    – Gnoupi
    May 2, 2010 at 14:02

3 Answers 3


Two things that I can see might be a problem.
The first question is are the operating systems the same? (UNIX / MS / MAC) all use different EOF characters. I haven't run into this on ZIP files but plenty of times on others.
The second is how old is the zip code / executable? The C / C++ direct file access uses a long integer to get it's file position. The maximum file size for this is 2GB.


as a feedback/follow up on this post for someone who could be interested i noticed something :

I tried unzipping a small zip file that was placed on the server, it gave me same error so what i did is download, extract, go to the folder content, select the files , zip them, upload, unzip - it worked.

troubleshooting the smaller file gives : zip -T filename.zip zip warning: missing end signature--probably not a zip file (did you zip warning: remember to use binary mode when you transferred it?)

I installed 7zip, tested it with a regular folder using 7za x filename.zip , it worked, but on this folder, it didn't sigh

could the error be a problem of "double zipping"...or the transmission mode, using my hunch in here...would appreciate your feedback

sadly the file i am facing a problem with is 2GB , no way i could download/upload that on my internet connection


i had the same issue while trying to download a large file from the microsoft TEAMS app. So I opened the same folder on chrome and downloaded it from there and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.