1

I'm clean installing windows 10 on a dell laptop (this is my third time installing windows on this machine; previously I had windows and ubuntu dual booting in EFI mode) using a USB installation drive, and it's failing.

In the partitioning step of the windows installation wizard, I delete all partitions (I don't have any data), then create a new partition. It then automatically creates a 500 MB recovery partition, a 100 MB system partition, and a 16 MB MSR partition, then finally my primary partition.

I then select the primary partition to install windows. I then get a warning that "the partitions on the disk selected for installation are not in the recommended order". I continue forward, and immediately get an error message saying "Windows detected that the EFI system partition was formatted as NTFS. Format it as FAT32, then restart the installation".

But the system partition was just created by windows itself 5 seconds ago. How can this be possible?

I found many other threads on many other sites on this issue. I tried shift+F10 then diskpart then clean, which deletes the partitions. Same problem still persists.

Why is it complaining about a step it did itself automatically? Is it creating the partitions out of order, then complaining about it?

when I go into diskpart and do list partition: I get the following:

Partition 1  Recovery  499 MB
Partition 2  System    100 MB
Partition 3  Reserved   16 MB
Partition 4  Primary    48 GB

Again, those are the partitions that were automatically created when I clicked "new" and made a 50,000 MB allocation. However, if I do list volume, I get this:

Volume 0   D                  DVD-ROM
Volume 1   E  Recovery  NTFS  Partition 499 MB
Volume 2                RAW   Partition  48 GB
Volume 3   F            FAT32 Partition 100 MB
Volume 4   C  SANDISK   FAT32 Removable  14 GB

First, the 100 MB, which I'm assuming is the EFI system partition, is FAT32, so the error message I got before is incorrect. However, something looks seriously wrong with the ordering and the letters here. C assigned to my USB drive? And why are the volumes a different order from the partitions?

What do I need to do to fix the issue above and actually install windows? This is my third time installing windows 10 on this machine, and the first two times worked without a hitch.

4

update:the issue went away after I recreated the usb drive using a different method.

the usb drive above was created by downloading the iso in windows using media creation tool, then burning to USB using unetbootin. (the media creation tool has a really nasty gotcha where if you choose to directly create a usb drive, it will download the 5 gb file, and then if your usb drive's partition table isn't exactly right [MBR instead of GPT, if I remember correctly], it will complain, then force you to restart the 5 gb download again.)

I downloaded the iso again on my macbook, then created usb using boot camp assistant (edit: this may not be possible anymore, see edit at bottom), then plugged it back into my dell, and this time the installation went through perfectly. After the partition step, I got neither the warning nor the error message.

It's really strange that if the original method of creating the USB drive corrupted the installation files in some way, the installer was still runnable.

Edit: as of September 2019, it appears that Boot Camp assistant can no longer create bootable Windows 10 usb drive. Also, the windows 10 media creation tool itself failed for me (after downloading the 5 gb image!), but Rufus was able to create a working bootable usb.

  • Thanks a million for this! I never even considered the possibility that my USB stick was the issue since it booted and ran the installer. I've been pulling my hair out for two hours trying to figure out what is going on. – PlexLuthor Aug 5 '19 at 4:30
  • Omg, you're right!! It totally failed due to the fact that my bootable USB stick had its own EFI system partition. I didn't notice until I re-created the USB drive (this time with Rufus) that there should only be a single Partition on my USB drive. Originally, I had created the USB drive on my mac using diskutil eraseDisk MS-DOS "WIN10" GPT disk2 as I had seen somewhere, which created the extraneous EFI system partition. – motto Sep 10 '19 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.